[SM-Grimoire-Bugs] [Bug 14566] New: blender 2.46 fails to compile on x86

bugzilla-daemon at bugs.sourcemage.org bugzilla-daemon at bugs.sourcemage.org
Wed Jul 9 17:21:14 EDT 2008


http://bugs.sourcemage.org/show_bug.cgi?id=14566

           Summary: blender 2.46 fails to compile on x86
           Product: Codex
           Version: test grimoire
          Platform: x86
        OS/Version: Linux
            Status: NEW
          Severity: normal
          Priority: P2
         Component: graphics
        AssignedTo: sm-grimoire-bugs at lists.ibiblio.org
        ReportedBy: sandalle at sourcemage.org


$ sorcery -v
1.14.1-rc3

$ gaze version blender ffmpeg ode openexr openal
Grimoire  Section     Spell    Grimoire Version  Installed Version
--------  -------     -----    ----------------  -----------------
test      graphics    blender  2.46              2.45
test      video       ffmpeg   20070219          20070219
test      libs        ode      0.9               0.9
test      graphics    openexr  1.6.1             1.6.1
test      audio-libs  openal   20050601          20050601

$ uname -m
i686

Seems to work fine on my x86_64 box, but not either of my x86 boxes.

On my x86_64 box:
$ cat /etc/sorcery/local/depends/blender.p
OPENAL="n"
OPENEXR="y"
ODE="y"
FFMPEG="y"

On my x86 boxes:
$ cat /etc/sorcery/local/depends/blender.p
OPENAL="n"
OPENEXR="y"
ODE="y"
FFMPEG="y"

# cast blender
Computing previously installed dependencies...
blender preparing environment...
blender running configuration...
[[ Use blender audio ability (freealut with openal) ? -> n ]]
[[ Enable High Dynamic Range graphics (openexr)? -> y ]]
[[ Enable Open Dynamics Engine support (ode) ? -> y ]]
[[ Use ffmpeg as a dependency? -> y ]]
blender checking dependencies...
blender has a dependency on python
blender has a dependency on scons
blender has a dependency on sdl
blender has a dependency on some GLUT.
Continue to use freeglut? [y]
blender has a dependency on zlib
blender has a dependency on jpeg
blender has a dependency on openexr
blender has a dependency on ode
blender has a dependency on some LIBAVCODEC.
Continue to use ffmpeg? [y]
blender has an enabled optional dependency on libpng
blender has an enabled optional dependency on yafray
...
Compiling ==> 'bitstream_filter.c'
Compiling ==> 'dsputil_mmx.c'
extern/ffmpeg/libavcodec/i386/dsputil_mmx.c: In function 'gmc_mmx':
extern/ffmpeg/libavcodec/i386/dsputil_mmx.c:2663: warning: suggest parentheses
around arithmetic in operand of |
extern/ffmpeg/libavcodec/i386/dsputil_mmx.c:2663: warning: suggest parentheses
around arithmetic in operand of |
extern/ffmpeg/libavcodec/i386/dsputil_mmx.c:2664: warning: suggest parentheses
around arithmetic in operand of |
extern/ffmpeg/libavcodec/i386/dsputil_mmx.c:2664: warning: suggest parentheses
around arithmetic in operand of |
extern/ffmpeg/libavcodec/i386/dsputil_mmx.c:2664: warning: suggest parentheses
around arithmetic in operand of |
extern/ffmpeg/libavcodec/i386/dsputil_mmx.c: In function 'dsputil_init_mmx':
extern/ffmpeg/libavcodec/i386/dsputil_mmx.c:3625: warning: assignment from
incompatible pointer type
extern/ffmpeg/libavcodec/i386/dsputil_mmx.c:3633: warning: assignment from
incompatible pointer type
extern/ffmpeg/libavcodec/i386/h264dsp_mmx.c: In function
'h264_h_loop_filter_luma_mmx2':
extern/ffmpeg/libavcodec/i386/dsputil_mmx.c:646: error: can't find a register
in class 'GENERAL_REGS' while reloading 'asm'
extern/ffmpeg/libavcodec/i386/dsputil_mmx.c:646: error: 'asm' operand has
impossible constraints
extern/ffmpeg/libavcodec/i386/dsputil_mmx.c:646: error: 'asm' operand has
impossible constraints
extern/ffmpeg/libavcodec/i386/dsputil_mmx.c:646: error: 'asm' operand has
impossible constraints
extern/ffmpeg/libavcodec/i386/dsputil_mmx.c:646: error: 'asm' operand has
impossible constraints
extern/ffmpeg/libavcodec/i386/h264dsp_mmx.c:387: error: 'asm' operand has
impossible constraints
extern/ffmpeg/libavcodec/i386/dsputil_mmx.c:646: error: 'asm' operand has
impossible constraints
extern/ffmpeg/libavcodec/i386/dsputil_mmx.c:646: error: 'asm' operand has
impossible constraints
scons: building terminated because of errors.
scons: *** [/usr/src/build/linux2/extern/ffmpeg/libavcodec/i386/dsputil_mmx.o]
Error 1

Disabling ffmpeg allows it to compile:
Computing previously installed dependencies...
blender preparing environment...
blender running configuration...
Use blender audio ability (freealut with openal) ? [n] n
Enable High Dynamic Range graphics (openexr)? [y] y
Enable Open Dynamics Engine support (ode) ? [y] y
Use ffmpeg as a dependency? [y] n
...
`/usr/src/blender-2.46/release/scripts/export_m3g.py' ->
`/usr/share/blender/scripts/export_m3g.py'
`/usr/src/blender-2.46/release/VERSION' -> `/usr/share/blender/VERSION'
Creating compile log /var/log/sorcery/compile/blender-2.46.bz2
Creating tablet in directory /var/state/sorcery/tablet/blender/20080709141912
Creating install log /var/log/sorcery/install/blender-2.46
Creating MD5 log /var/log/sorcery/md5sum/blender-2.46
Creating cache file /var/cache/sorcery/blender-2.46-i686-pc-linux-gnu.tar.bz2
Finished processing install requests.

Spells installed successfully:
------------------------------
blender

Why does this work on x86_64, but not x86? ffmpeg is configured the same on all
three boxes (two x86, one x86_64):
$ cat /etc/sorcery/local/depends/ffmpeg.p
FFAMR="none"


-- 
Configure bugmail: http://bugs.sourcemage.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug.



More information about the SM-Grimoire-Bugs mailing list