[SM-Grimoire-Bugs] [Bug 14628] New: gcc-4.3.1cast aborts with internal compiler error on amd64

bugzilla-daemon at bugs.sourcemage.org bugzilla-daemon at bugs.sourcemage.org
Sun Aug 10 06:00:32 EDT 2008


http://bugs.sourcemage.org/show_bug.cgi?id=14628

           Summary: gcc-4.3.1cast aborts with internal compiler error on
                    amd64
           Product: Codex
           Version: test grimoire
          Platform: x86-64
        OS/Version: All
            Status: NEW
          Severity: blocker
          Priority: P2
         Component: gnu
        AssignedTo: sm-grimoire-bugs at lists.ibiblio.org
        ReportedBy: sobukus at sourcemage.org


Created an attachment (id=7095)
 --> (http://bugs.sourcemage.org/attachment.cgi?id=7095)
compile log

I am building a x86-64 install (AsRock K8Upgrade-VM800 board, 2,2GHz Athlon64,
1G RAM) and started to upgrade to test grimoire after installing from the
silver thistle ISO.

Got stuck at upgrading gcc from 4.0.? to 4.3.1.

Cast always crashes (segfault, even) at libiberty/hashtab.c:554 .
I tried this without special optimization (speedy or such) and with the normal
and minimal k8 archspecs; actually not sure if I even tried it _with_ speedy.

The log always looks something like what I'm going to attach...

I switched to stable now, gcc-4.2.3 casting without trouble.

Any hints on that one? Should I file a gcc bug?
I don't have other strange compile failures... hardware looks fine to me,
compiling other stuff through the night.


-- 
Configure bugmail: http://bugs.sourcemage.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug.



More information about the SM-Grimoire-Bugs mailing list