[SM-Grimoire-Bugs] [Bug 14488] New: kdebase4-runtime: DEPENDS changes

bugzilla-daemon at bugs.sourcemage.org bugzilla-daemon at bugs.sourcemage.org
Fri Apr 25 12:50:39 EDT 2008


http://bugs.sourcemage.org/show_bug.cgi?id=14488

           Summary: kdebase4-runtime: DEPENDS changes
           Product: Codex
           Version: test grimoire
          Platform: Other
        OS/Version: other
            Status: NEW
          Severity: normal
          Priority: P2
         Component: kde
        AssignedTo: sm-grimoire-bugs at lists.ibiblio.org
        ReportedBy: carlosdgtorres at gmail.com


kdebase/runtime now requires Xine in order to build. It also (optionally)
requires Xine be built with XCB support. There are also optional dependencies
that aren't in the DEPENDS script of kdebase4-runtime. Here are some proposed
changes. I'm attaching a patch as well as build logs of kdebase4-runtime without
Xine and with Xine but without XCB.

kdebase4-runtime
 * make xine-lib a required dependency (attach build log w/o xine)
 * make libxcb a required dependency (needed for video support)
 * added optional dependency on openexr for EXR support in thumbnails
 * added optional dependency on samba for building the smb-ioslaves

-- 
Configure bugmail: http://bugs.sourcemage.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug, or are watching the assignee.



More information about the SM-Grimoire-Bugs mailing list