[SM-Grimoire-Bugs] [Bug 14465] New: swiprolog version update, minor fixes

bugzilla-daemon at bugs.sourcemage.org bugzilla-daemon at bugs.sourcemage.org
Fri Apr 18 11:53:42 EDT 2008


http://bugs.sourcemage.org/show_bug.cgi?id=14465

           Summary: swiprolog version update, minor fixes
           Product: Codex
           Version: test grimoire
          Platform: Other
        OS/Version: other
            Status: NEW
          Severity: normal
          Priority: P2
         Component: devel
        AssignedTo: sm-grimoire-bugs at lists.ibiblio.org
        ReportedBy: sqweek at gmail.com


Went to cast swiprolog 5.6.25, but the source doesn't exist on the original
webserver anymore, and the cgi script gives an annoying error message instead of
a 404.
 So I bumped the version to 5.6.54 (latest stable), switched the SOURCE_URL to
the direct ftp url, and while I was there noticed a distinct lack of DEPENDS -
netbsd[1] and debian[2] both claim it depends on gmp/ncurses/readline which I am
inclined to believe so I've added that too.

[1] http://pkgsrc.se/lang/swi-prolog-lite
[2] http://packages.debian.org/sid/swi-prolog

 OK, and then I went to install it, and the jpl extra package failed because of
some autoconf stuff. Anyway long story short, I pretty much overhauled the whole
spell adding optional dependencies for the different packages and stuff and now
it kicks ass and works.
 Patch coming up.
-sqweek

-- 
Configure bugmail: http://bugs.sourcemage.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug, or are watching the assignee.



More information about the SM-Grimoire-Bugs mailing list