[SM-Grimoire-Bugs] [Bug 14015] New: binutils 2.18 fails to install

bugzilla-daemon at bugs.sourcemage.org bugzilla-daemon at bugs.sourcemage.org
Wed Sep 26 21:24:34 EDT 2007


http://bugs.sourcemage.org/show_bug.cgi?id=14015

           Summary: binutils 2.18 fails to install
           Product: Codex
           Version: test grimoire
          Platform: All
        OS/Version: Linux
            Status: NEW
          Severity: normal
          Priority: P2
         Component: devel
        AssignedTo: sm-grimoire-bugs at lists.ibiblio.org
        ReportedBy: sandalle at sourcemage.org


# sorcery -v
1.13.7-rc2

# cast binutils
Making info in doc
make[3]: Entering directory `/usr/src/binutils-2.18/buildit/bfd/doc'
restore=: && backupdir=".am$$" && \
        rm -rf $backupdir && mkdir $backupdir && \
        if (/usr/src/binutils-2.18/missing makeinfo --split-size=5000000
--split-size=5000000 --version) >/dev/null 2>&1; then \
          for f in bfd.info bfd.info-[0-9] bfd.info-[0-9][0-9] bfd.i[0-9]
bfd.i[0-9][0-9]; do \
            if test -f $f; then mv $f $backupdir; restore=mv; else :; fi; \
          done; \
        else :; fi && \
        if /usr/src/binutils-2.18/missing makeinfo --split-size=5000000
--split-size=5000000   -I ../../../bfd/doc \
         -o bfd.info `test -f 'bfd.texinfo' || echo
'../../../bfd/doc/'`bfd.texinfo; \
        then \
          rc=0; \
        else \
          rc=$?; \
          $restore $backupdir/* `echo "./bfd.info" | sed 's|[^/]*$||'`; \
        fi; \
        rm -rf $backupdir; exit $rc
WARNING: `makeinfo' is missing on your system.  You should only need it if
         you modified a `.texi' or `.texinfo' file, or any other file
         indirectly affecting the aspect of the manual.  The spurious
         call might also be the consequence of using a buggy `make' (AIX,
         DU, IRIX).  You might want to install the `Texinfo' package or
         the `GNU make' package.  Grab either from any GNU archive site.
make[3]: *** [bfd.info] Error 1
make[3]: Leaving directory `/usr/src/binutils-2.18/buildit/bfd/doc'
Making info in po
make[3]: Entering directory `/usr/src/binutils-2.18/buildit/bfd/po'
make[3]: Nothing to be done for `info'.
make[3]: Leaving directory `/usr/src/binutils-2.18/buildit/bfd/po'
make[3]: Entering directory `/usr/src/binutils-2.18/buildit/bfd'
make[3]: Nothing to be done for `info-am'.
make[3]: Leaving directory `/usr/src/binutils-2.18/buildit/bfd'
make[2]: *** [info-recursive] Error 1
make[2]: Leaving directory `/usr/src/binutils-2.18/buildit/bfd'
make[1]: *** [all-bfd] Error 2
make[1]: Leaving directory `/usr/src/binutils-2.18/buildit'
make: *** [all] Error 2

I have tried compiling texinfo (provider of makeinfo), but that does not fix the
problem. texinfo was just upgraded from 4.9 to 4.11.

# dispel --nosustain -d texinfo 4.9
Installed: texinfo  to version 4.9

# gaze version texinfo
Grimoire  Section  Spell    Grimoire Version  Installed Version
--------  -------  -----    ----------------  -----------------
test      latex    texinfo  4.11              4.9

# cast -c binutils
Runs successfully

Trying texinfo 4.11 again:
# cast -c texinfo binutils
binutils fails with the same error

Reverting 74023c56b5809638097452e631ee388c57d82822 (texinfo 4.11 update) for now.

-- 
Configure bugmail: http://bugs.sourcemage.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug, or are watching the assignee.



More information about the SM-Grimoire-Bugs mailing list