[SM-Grimoire-Bugs] [Bug 14004] New: glibc sometimes fails to compile when testing for an acceptable grep

bugzilla-daemon at bugs.sourcemage.org bugzilla-daemon at bugs.sourcemage.org
Thu Sep 20 11:57:15 EDT 2007


http://bugs.sourcemage.org/show_bug.cgi?id=14004

           Summary: glibc sometimes fails to compile when testing for an
                    acceptable grep
           Product: Codex
           Version: stable grimoire
          Platform: All
        OS/Version: All
            Status: NEW
          Severity: normal
          Priority: P2
         Component: libs
        AssignedTo: sm-grimoire-bugs at lists.ibiblio.org
        ReportedBy: sandalle at sourcemage.org
                CC: dmlb2000 at gmail.com


# sorcery -v
1.13.6

# gaze version glibc
Grimoire  Section  Spell  Grimoire Version  Installed Version
--------  -------  -----  ----------------  -----------------
test      libs     glibc  2.4               2.3.6

# cast glibc
Computing previously installed dependencies...
glibc preparing environment...
[[ As you are running a 2.6 kernel, would you like to use the new nptl (Native
Posix Thread Libary)? -> y ]]
[[ Would you like to compile glibc with libidn support? -> y ]]
[[ Shall the dynamic linker install to /lib (not /lib64) (lib64 purge  part 2 of
2)? -> y ]]
glibc checking dependencies...
...
running configure fragment for sysdeps/pthread
running configure fragment for sysdeps/unix/sysv/linux
checking for grep that handles long lines and -e... Usage: /usr/bin/grep
[OPTION]... PATTERN [FILE]...
Try `/usr/bin/grep --help' for more information.
configure: error: no acceptable grep could be found in
/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin:/usr/X11R6/bin:/usr/xpg4/bin
make[1]: Failed to remake makefile `/usr/src/glibc-2.4.bld/config.make'.
rm -f /usr/src/glibc-2.4.bld/stamp.o; > /usr/src/glibc-2.4.bld/stamp.o
rm -f /usr/src/glibc-2.4.bld/stamp.os; > /usr/src/glibc-2.4.bld/stamp.os
rm -f /usr/src/glibc-2.4.bld/stamp.oS; > /usr/src/glibc-2.4.bld/stamp.oS
cd /usr/src/glibc-2.4.bld &&
/usr/lib/gcc/x86_64-pc-linux-gnu/4.1.2/../../../../x86_64-pc-linux-gnu/bin/ar
cruv libc.a `cat stamp.o`
: /usr/src/glibc-2.4.bld/libc.a
cd /usr/src/glibc-2.4.bld &&
/usr/lib/gcc/x86_64-pc-linux-gnu/4.1.2/../../../../x86_64-pc-linux-gnu/bin/ar
cruv libc_pic.a `cat stamp.os`
: /usr/src/glibc-2.4.bld/libc_pic.a
cd /usr/src/glibc-2.4.bld &&
/usr/lib/gcc/x86_64-pc-linux-gnu/4.1.2/../../../../x86_64-pc-linux-gnu/bin/ar
cruv libc_nonshared.a `cat stamp.oS`
: /usr/src/glibc-2.4.bld/libc_nonshared.a
make[1]: *** No rule to make target `/usr/src/glibc-2.4.bld/Versions.all',
needed by `/usr/src/glibc-2.4.bld/abi-versions.h'.  Stop.
make[1]: Leaving directory `/usr/src/glibc-2.4'
make: *** [all] Error 2
 ! Problem Detected !

George also had this problem on an x86 box back in November 2006:
http://lists.ibiblio.org/pipermail/sm-discuss/2006-November/015824.html

David Brown suggests trying the as-test-x.patch from glibc-2.6 in devel, which
as submitted with commit 199874422bbb17772cb0257187151007ab398463 (which
includes the update to 2.6.1, so we can't cherry-pick). Applying the
as-test-x.patch to glibc 2.4 allows glibc to compile.

-- 
Configure bugmail: http://bugs.sourcemage.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug, or are watching the assignee.



More information about the SM-Grimoire-Bugs mailing list