[SM-Grimoire-Bugs] [Bug 14060] New: kdegraphics needs fribidi to compile ksvg

bugzilla-daemon at bugs.sourcemage.org bugzilla-daemon at bugs.sourcemage.org
Wed Oct 24 03:16:50 EDT 2007


http://bugs.sourcemage.org/show_bug.cgi?id=14060

           Summary: kdegraphics needs fribidi to compile ksvg
           Product: Codex
           Version: stable grimoire
          Platform: PPC
        OS/Version: Linux
            Status: NEW
          Severity: normal
          Priority: P2
         Component: kde
        AssignedTo: sm-grimoire-bugs at lists.ibiblio.org
        ReportedBy: carlosdgtorres at gmail.com


kdegraphics has an optional dependency to fribidi that is not included in the 
DEPENDS for the spell. fribidi is one of the requirements in order to build 
KSVG. This optional dependency is checked in the configure script.

For example:

if test -z "$LCMS_LIBS" -o -z "$LIBART_LIBS" -o \
        -z "$FREETYPE_LIBS" -o -z "$FRIBIDI_LIBS" -o -z "$FONTCONFIG_LIBS"; 
then
  echo ""
  echo "Some of the libraries required for KSVG are missing or too old,"
  echo "therefore KSVG will not be compiled."
  echo ""
  echo "If you want to compile KSVG you should install:"
  if test -z "$LCMS_LIBS"; then
    echo "  * lcms 1.09 or newer (http://www.littlecms.com/)"
  fi
  if test -z "$LIBART_LIBS"; then
    echo "  * libart 2.3.8 or newer (http://www.levien.com/libart/)"
  fi
  if test -z "$FREETYPE_LIBS"; then
    echo "  * freetype 2.0.6 or newer (http://www.freetype.org)"
  fi
  if test -z "$FONTCONFIG_LIBS"; then
    echo "  * fontconfig 2.2.0 or newer (http://fontconfig.org)"
  fi
  if test -z "$FRIBIDI_LIBS"; then
    echo "  * fribidi 0.10.4 or newer 
(http://freedesktop.org/Software/FriBidi)"
  fi
  echo ""
  all_tests=bad
fi

-- 
Configure bugmail: http://bugs.sourcemage.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug, or are watching the assignee.



More information about the SM-Grimoire-Bugs mailing list