[SM-Grimoire-Bugs] [Bug 13423] New: sudo defaults to nano when upstream would use vi

bugzilla-daemon at bugs.sourcemage.org bugzilla-daemon at bugs.sourcemage.org
Fri Jan 19 00:13:06 EST 2007


http://bugs.sourcemage.org/show_bug.cgi?id=13423

           Summary: sudo defaults to nano when upstream would use vi
           Product: Codex
           Version: stable grimoire
          Platform: Other
        OS/Version: other
            Status: NEW
          Severity: normal
          Priority: P2
         Component: utils
        AssignedTo: sm-grimoire-bugs at lists.ibiblio.org
        ReportedBy: jblosser-smgl at firinn.org


# gaze BUILD sudo
EDITOR=`which  ${EDITOR%% *}  2>/dev/null`  ||
EDITOR=`which  nano`                        &&
OPTS="$OPTS --with-editor=$EDITOR"          &&
default_build


This does not equal sticking to upstream defaults, which would default to vi.
This should be changed to at least not passing --with-editor if $EDITOR isn't
set, and should probably prompt the user to either pass $EDITOR or use $EDITOR
at runtime or just use the default (which would be vi).

-- 
Configure bugmail: http://bugs.sourcemage.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug, or are watching the assignee.



More information about the SM-Grimoire-Bugs mailing list