[SM-Grimoire-Bugs] [Bug 13381] New: init.d install should be dependency-aware

bugzilla-daemon at bugs.sourcemage.org bugzilla-daemon at bugs.sourcemage.org
Sun Jan 7 06:12:12 EST 2007


http://bugs.sourcemage.org/show_bug.cgi?id=13381

           Summary: init.d install should be dependency-aware
           Product: Codex
           Version: z-rejected grimoire
          Platform: Other
        OS/Version: other
            Status: NEW
          Severity: normal
          Priority: P2
         Component: FUNCTIONS
        AssignedTo: sm-grimoire-bugs at lists.ibiblio.org
        ReportedBy: seth at swoolley.homeip.net


Pie in the sky, but I'll try anyways...

installing an init script that NEEDS some other script or providers should make
sure to ask the user if they want to enable the dependencies if not already
installed.  If the spell is already installed and the init script is not
installed or enabled, then a telinit spellinstall should be run, however, we
should do that only after telinit spellinstall actually tracks its changes with
"alter" (or some other tracking system) so we get persistent changes.  So it's
really two separate bugs.

I don't think any of this involves sorcery, but it might (as in removing more
init code to be factored out of sorcery).

-- 
Configure bugmail: http://bugs.sourcemage.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug, or are watching the assignee.



More information about the SM-Grimoire-Bugs mailing list