[SM-Grimoire-Bugs] [Bug 13082] aterm spell has unnecessary dependency

bugzilla-daemon at bugs.sourcemage.org bugzilla-daemon at bugs.sourcemage.org
Fri Sep 8 03:18:36 EDT 2006


http://bugs.sourcemage.org/show_bug.cgi?id=13082





------- Additional Comments From hgr at vabo.cz  2006-09-08 02:18 -------
Just updated aterm to 1.0.0 (test grimoire).
It really doesn't need afterstep.
It should be probably only optional_depends.

"gaze compile aterm" without afterstep:

checking if distributed as part of AfterStep... no
checking installed libAfterImage... afterimage-config not found - no AfterStep i
ntegration available.
AfterStep integration
To enable background image support you will need to download and install
libAfterImage from ftp://ftp.afterstep.org/stable/libAfterImage/ and then re-run
 this script.

"gaze compile aterm" with installed afterstep:

checking if distributed as part of AfterStep... no
checking installed libAfterImage... -lAfterImage -lAfterBase -lfreetype -lz -lti
ff -lX11 -L/usr/X11R6/lib -lSM -lICE -lXext -ljpeg -lpng -lz -lm
checking libAfterStep... -lAfterStep -lXinerama -lXext


Without installed afterstep you can't set the backgroud of terminal (aterm
-pixmap aa.jpg). Exactly you need afterstep or only libAfterImage. This library
is a part of afterstep but it is also possible to install it solo (we have not
spell for it).

-- 
Configure bugmail: http://bugs.sourcemage.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug, or are watching the assignee.



More information about the SM-Grimoire-Bugs mailing list