[SM-Grimoire-Bugs] [Bug 12650] New: synaptics needs some patches

bugzilla-daemon at bugs.sourcemage.org bugzilla-daemon at bugs.sourcemage.org
Fri Jun 9 13:02:26 EDT 2006


http://bugs.sourcemage.org/show_bug.cgi?id=12650

           Summary: synaptics needs some patches
           Product: Codex
           Version: test grimoire
          Platform: x86
        OS/Version: Linux
            Status: NEW
          Severity: normal
          Priority: P2
         Component: xorg-modular
        AssignedTo: sm-grimoire-bugs at lists.ibiblio.org
        ReportedBy: timothee.lecomte at ens.fr


The spell synaptics won't compile as is. It complains about "conflicting types". 


The following page lists two patches for 0.14.4 :
http://rpmfind.net//linux/RPM/fedora/devel/src/synaptics-0.14.4-7.src.html

The first one (synaptics-0.14.4-delibcwrap.patch) will remove the conflicting
types. The second one (synaptics-0.14.4-modularx.patch) will make it compile for
modular X.

The second one has been integrated in the upstream 0.14.5 version, which has
been released a few days ago. The first one will apply to 0.14.5 with some
harmless rejects, and it is needed to change one remaining xf86sscanf() by
sscanf() in synaptics.c

Then we will have a functional synaptics spell !

-- 
Configure bugmail: http://bugs.sourcemage.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug, or are watching the assignee.



More information about the SM-Grimoire-Bugs mailing list