[SM-Grimoire-Bugs] [Bug 10475] New: default_build and default_install are buggy[fix noted]

bugzilla-daemon at bugs.sourcemage.org bugzilla-daemon at bugs.sourcemage.org
Mon Jan 30 05:57:48 EST 2006


http://bugs.sourcemage.org/show_bug.cgi?id=10475

           Summary: default_build and default_install are buggy[fix noted]
           Product: Codex
           Version: test grimoire
          Platform: Other
        OS/Version: other
            Status: NEW
          Severity: normal
          Priority: P2
         Component: gnustep-libs
        AssignedTo: sm-grimoire-bugs at lists.ibiblio.org
        ReportedBy: ruskie at email.si


You're missing && in them...

The following code has it and works as it should...
This bug affects both -libs and -apps
function default_build ()
{
    if [ -f /etc/profile.d/GNUstep.sh ]
    then
	. /etc/profile.d/GNUstep.sh
    else
	message "${ERROR_COLOR}Unable to find /etc/profile.d/GNUstep.sh"
	message "Rebuild gnustep-make${DEFAULT_COLOR}"
	exit 1
    fi                                                                   &&

    if [ -f ./configure ]
    then
	./configure                                                      \
	$OPTS                                                            
    fi                                                                   &&

    make                                                                 &&

    if [ "$GNUSTEP_BUILD_DOC" == "y" ]
    then
	cd Documentation                                                 &&
	make                                                             &&
	cd ../                                        
    fi
}

function default_install ()
{
    make GNUSTEP_INSTALLATION_DIR=$GNUSTEP_SYSTEM_ROOT install           &&

    if [ "$GNUSTEP_BUILD_DOC" == "y" ]
    then
	cd Documentation                                                  &&
	make                                                              &&
	make GNUSTEP_INSTALLATION_DIR=$GNUSTEP_SYSTEM_ROOT install        &&
	cd ../
    fi
}

-- 
Configure bugmail: http://bugs.sourcemage.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug, or are watching the assignee.



More information about the SM-Grimoire-Bugs mailing list