[SM-Grimoire-Bugs] [Bug 10564] New: dbus > 0.50 needs qt >= 4.0

bugzilla-daemon at bugs.sourcemage.org bugzilla-daemon at bugs.sourcemage.org
Tue Feb 21 02:26:12 EST 2006


http://bugs.sourcemage.org/show_bug.cgi?id=10564

           Summary: dbus > 0.50 needs qt >= 4.0
           Product: Codex
           Version: test grimoire
          Platform: Other
        OS/Version: other
            Status: NEW
          Severity: normal
          Priority: P2
         Component: utils
        AssignedTo: sm-grimoire-bugs at lists.ibiblio.org
        ReportedBy: josebernardo1 at yahoo.com


dbus can't be updated to a version after 0.50, as it will need qt-x11 >= to 4.0.
As most apps will only use qt 4 after kde 4 is released, it seems a bit
premature to be breaking all compatibility now with a dbus update. I propose it
should be a WIP until kde starts using qt 4 too.

checking DBUS_GTK_THREADS_LIBS... -pthread -lgtk-x11-2.0 -lgdk-x11-2.0 -latk-1.0
-lgdk_pixbuf-2.0 -lm
+-lpangocairo-1.0 -lpango-1.0 -lcairo -lgobject-2.0 -lgmodule-2.0 -ldl
-lgthread-2.0 -lglib-2.0
checking for moc... /usr/bin/moc
checking for qglobal.h... found
checking for QtCore >= 4.0... configure: WARNING: Qt development libraries not found
configure: error: Qt integration explicitly required, and Qt libraries not found
 ! Problem Detected !

-- 
Configure bugmail: http://bugs.sourcemage.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug, or are watching the assignee.



More information about the SM-Grimoire-Bugs mailing list