[freetds] New to FreeTDS - Having issues with binaries built on Windows for PHP 5.6

Thomas Royko TRoyko at sscorp.com
Fri Jun 12 09:19:40 EDT 2015


Well, interestingly enough rolling back to freetds 0.92.79  seems to work.  As for the error I was getting, this is what was coming up on php's end:

PHP Fatal error:  Must register a driver log function. in Unknown on line 0

Anyways I'm just happy I have a workaround right now.

-Thomas Royko

From: Thomas Royko
Sent: Tuesday, June 9, 2015 5:43 PM
To: 'freetds at lists.ibiblio.org'
Subject: New to FreeTDS - Having issues with binaries built on Windows for PHP 5.6

I don't know if my earlier message got sent properly, so I'm sending it again.

------------------------------------------------------------------------------------------------

I work for a company that has a large established PHP codebase, we intend to migrate it to PHP version 5.6 and run it under IIS.

So far I've followed the directions laid out in:

http://www.freetds.org/userguide/osissues.htm
https://moodle.org/mod/forum/discuss.php?d=232844#p1012743

I am using VC11.

I've built FreeTDS and built the corresponding php_dblib.dll, but when I try to connect with PHP, I get unable to connect errors in my php.
I'm using the same config file I have been using with earlier prebuilt versions of FreeTDS (which worked under PHP 5.4).

On a side note I didn't run configure before building freetds because as far as I know there's no way to do it without something like mysys.  And if you have mysys it sets up everything to point to the gcc, making nmake fail on build.

PS.  I know this email is scant on information.  But any help would be greatly appreciated.

-Thomas R.


More information about the FreeTDS mailing list