[freetds] Kerberos connection from Ubuntu 15.04 not working (also tried 14.10)

Laurence Dawson larry.dawson at gmail.com
Tue Jun 2 16:49:38 EDT 2015


I have tried both tsql -S sqlhostname and tsql -S sqlhosthame -U '' -P ''
as suggested in a previous similar message on this list. My login is
failing with the error below in both cases.

I have established a tgt using kinit, but have not 'joined the domain' with
this machine. It doesn't seem like that should be necessary, as I'm just
trying to connect with my user principal:


fakeuser at lpdt430lub:~$ KRB5_TRACE=krb5.log TDSDUMP=tds.log
/opt/freetds/bin/tsql -S prod1 -U '' -P ''
locale is "en_US.UTF-8"
locale charset is "UTF-8"
using default charset "UTF-8"
Error 20002 (severity 9):
Adaptive Server connection failed
There was a problem connecting to the server



fakeuser at lpdt430lub:~$ klist
Ticket cache: FILE:/tmp/krb5cc_1000
Default principal: My.Username at INT.MYCOMPANY.COM

Valid starting       Expires              Service principal
06/02/2015 14:53:56  06/03/2015 00:53:56  krbtgt/
INT.MYCOMPANY.COM at INT.MYCOMPANY.COM
renew until 06/03/2015 14:53:52

[Note that I have edited the text above, and the log files to replace my
username and company name with fakes - at least for simple text searches]

TDS Version info:
Compile-time settings (established with the "configure" script)
                            Version: freetds v0.95rc3
             freetds.conf directory: /opt/freetds-0.95rc3/etc
     MS db-lib source compatibility: yes
        Sybase binary compatibility: no
                      Thread safety: yes
                      iconv library: yes
                        TDS version: 7.2
                              iODBC: no
                           unixodbc: no
              SSPI "trusted" logins: no
                           Kerberos: yes
                            OpenSSL: yes
                             GnuTLS: no
-------------- next part --------------
A non-text attachment was scrubbed...
Name: krb5.log
Type: application/octet-stream
Size: 1980 bytes
Desc: not available
URL: <http://lists.ibiblio.org/pipermail/freetds/attachments/20150602/50f8c2f7/attachment-0002.obj>
-------------- next part --------------
A non-text attachment was scrubbed...
Name: tds.log
Type: application/octet-stream
Size: 19179 bytes
Desc: not available
URL: <http://lists.ibiblio.org/pipermail/freetds/attachments/20150602/50f8c2f7/attachment-0003.obj>


More information about the FreeTDS mailing list