[freetds] Does logging work on Windows XP?

richard at xentu.com richard at xentu.com
Tue Apr 22 17:00:45 EDT 2014


On 2014-04-21 15:36, Ramiro Morales wrote:
> 
> Logging worked so this is another data point that'd suggest your
> problem is a FS permisson thing.

Well, the application trying to use freetds is the first thing I've 
tried writing using Lazarus. I have two dll files, freetds.conf & the 
Lazarus app all in the same directory:

dblib.dll
libiconv2.dll
freetds.conf
project1.exe

Provided encryption at the server end is switched off (and it's problems 
with that which make me want to see the logs), the app connects & gets a 
grid full of data from the remote MSSQL database. So, it must be reading 
freetds.conf file.

I'm just logged in as myself & invoking project1.exe. I certainly have 
permissions to create files anywhere. I did try locations other than 
c:\freetds.log, including just
dump file = freetds.log
thinking that might generate the log in the same directory as the 
application.

Would that not rule out file permissions as the source of the problem?


Richard



More information about the FreeTDS mailing list