[freetds] error: native binds to function params on sql server

Clovis Fabricio nosklo at gmail.com
Wed Jul 7 16:38:50 EDT 2010

2010/7/1 Frediano Ziglio <freddy77 at gmail.com>:
> It seems your not that patched SQL Server version does not like the
> way FreeTDS prepare the statement and this lead to some memory errors.
> We could try to replace a NULL parameter with a dummy one but is more
> complicated for me to explain how you could do this test that trying
> by myself... Could you manage to provide me an access (privately
> obviously) to this SQL Server to try??

Hello Frediano,

First of all, thank you for your answer and help.

Unfortunately this server is on my employee's internal network and not
exposed on the open internet.

I'd gladly run any code you provide against the server if you want,
and report back the results to you.

I have already downloaded latest freetds CVS source code and tried to
compile it, with success, but I'm still trying to figure out how to
convince unixodbc to use my compiled version. I though that only
changing odbcinst.ini would be enough, however it seems to point to
some libtdsS.so which haven't been built by default. I guess that's a
separate issue and if I can't figure it out I'll start another thread.

I have some news that can help the issue:

The code I originally posted prints the version as reported by odbc.
As I said, the problematic SQL Server is reporting '08.00.0760' as the

I have two other copies of SQL Server 2000 around so I tried the code
against them. They report versions 08.00.2039 and 08.00.2187 and both
run the code fine. So you're right about the exact patched version
'08.00.0760' as being related to the problem.

If there's anything else I can do to help find the problem, please tell me...

Again, thanks in advance.


More information about the FreeTDS mailing list