[freetds] unixodbc and freetds: v 0.62 works, v0.82 not

Jens Carl ml04 at reventix.de
Thu Jan 7 11:55:46 EST 2010

Hello List,

I recently switched form FreeTDS v0.63 to v0.82 because of the update
from Debian Etch to Lenny. The unixodbc version I'm using and MSSQL
server I'm connecting are the same.

I can establish a connection to server via odbc and sent data to server.
But by some of my select statements I get the error message "SQL state:
01000;Native Error Code: 20017;Error Message: [FreeTDS][SQL
Server]Unexpected EOF from the server". First I thought that something
in my configuration wasn't working so I tried some change to the TDS
Version (tried version 4.2, 5.0, and 7.0) and how I connect to the MSSQL
server, but that didn't helped.

So I made some tests with my select statement and found out that if the
statement has a particular length then the error occurred. This is
happing when the statement has to be send in more the one message to the
server (seen by a tcpdump trace). All the message are sent to server and
then server didn't answer and FreeTDS/ODBC is closing the connection
with the error.

I have seen the post
http://lists.ibiblio.org/pipermail/freetds/2009q4/025264.html which had
a similar problem so maybe there is already a solution?

Best regards


More information about the FreeTDS mailing list