[freetds] Sending dbnumeric in dbrpcparam

Damien Churchill damoxc at gmail.com
Mon Jun 1 10:31:35 EDT 2009


2009/5/29 James K. Lowden <jklowden at freetds.org>:
> Damien Churchill wrote:
>> 'The incoming tabular data stream (TDS) remote procedure call (RPC)
>> protocol stream is incorrect. Parameter 1 ("@idecimal"): Data type
>> 0x6A has an invalid data length or metadata length.'
>>
>>
>> Here is the code that I've tried: http://pastebin.com/f69a761d7
>
> http://manuals.sybase.com/onlinebooks/group-cnarc/cng1110e/dblib/@Generic__BookTextView/34413;pt=39614
>
>        "The value of type indicates the datatype of *value. See "Types" for more
> information. For types that have no C equivalent, such as SYBDATETIME,
> SYBMONEY, SYBNUMERIC, or SYBDECIMAL, use dbconvert_ps to initialize
> *value."
>
> HTH.
>
> --jkl
>

Hmm, I gave this a try and it still fails with the same error. Would
this only work with Sybase perhaps? Forgot to say that this is for MS
Sql Server.

Damien



More information about the FreeTDS mailing list