[freetds] tsql Memory fault on HP-UX

Kitt, Jeffrey jeffrey.kitt at hrblock.com
Wed May 6 11:42:43 EDT 2009


Help... I'm trying to get FreeTDS to work on an HP-UX server but have
run into a problem that
I can't figure out.  I'm relatively new to the Unix world and I'm just
feeling my way through
all of this.  I've tried to include all of the relavent information in
this email to avoid some
of the back and forth that I've seen on the message board while trying
to research this on my
own.  Any help would be appreciated.  Any advice should be clearly
spelled out since I'm new
to the Unix platform. Here are the particulars...
 

When I run tsql I am getting a "Memory fault" message and the
application terminates.  Here is the 
screen output that I am receiving...
 
/usr/local/freetds/bin (dolphin) $ tsql -U ****** -P ******** -S apptmgr
<
locale is "C C C C C C"
locale charset is "roman8"
Memory fault
/usr/local/freetds/bin (dolphin) $
 

This is the output captured in the dump file I specified in my
.freetds.conf file.....
 

log.c:190:Starting log file for FreeTDS 0.82.1.dev.20090404
 on 2009-05-06 09:35:02 with debug flags 0x4fff.
iconv.c:197:names for ISO-8859-1: ISO8859-1
iconv.c:197:names for UTF-8: UTF-8
iconv.c:197:names for UCS-2LE: UCS-2LE
iconv.c:197:names for UCS-2BE: UCS-2BE
iconv.c:363:iconv to convert client-side data to the "roman8" character
set
iconv.c:516:tds_iconv_info_init: converting "ROMAN8"->"UCS-2LE"
iconv.c:516:tds_iconv_info_init: converting "ISO-8859-1"->"UCS-2LE"
net.c:210:Connecting to 10.10.51.116 port 40140 (TDS version 7.0)
net.c:264:tds_open_socket: connect(2) returned "Operation now in
progress"
net.c:303:tds_open_socket() succeeded
util.c:162:Changed query state from DEAD to IDLE
login.c:735:quietly sending TDS 7+ login packet
 
 
 
This is the screen output when I run tsql under gdb....
 

Confidential computer software. Valid license from HP required for
possession, use or copying.  Consistent with FAR 12.211 and 12.212,
Commercial Computer Software, Computer Software Documentation, and
Technical Data for Commercial Items are licensed to the U.S. Government
under vendor's standard commercial license.
 
/home/a604355 (dolphin) $ cd /usr/local/freetds/bin
/usr/local/freetds/bin (dolphin) $ gdb tsql
HP gdb 5.7 for HP Itanium (32 or 64 bit) and target HP-UX 11.2x.
Copyright 1986 - 2001 Free Software Foundation, Inc.
Hewlett-Packard Wildebeest 5.7 (based on GDB) is covered by the
GNU General Public License. Type "show copying" to see the conditions to
change it and/or distribute copies. Type "show warranty" for
warranty/support.
..
(gdb) run -S apptmgr -U ******* -P *******
Starting program: /usr/local/freetds/bin/tsql -S apptmgr -U ******* -P
*******
locale is "C C C C C C"
locale charset is "roman8"
[New process 15111]
warning: reading register 584: No such process
Detaching after fork from process 15111
 
Program received signal SIGSEGV, Segmentation fault
  si_code: 2 - SEGV_ACCERR - Invalid Permissions for object.
0x200000007eacf5b0:0 in .text + 0xd0 ()
   from /usr/lib/nls/iconv/hpux32/methods.1/lsbucode.so
1262txi
1266yrogram is running.  Exit anyway? (y or n)
/usr/local/freetds/bin (dolphin) $
 
 
 
The gdb session does not terminate on its own so I can't get a backtrace
listing from gdb.
The gdb session just seems to be counting up without any end in sight.

The machine specs that this is running on are...
 
/usr/local/freetds/bin (dolphin) $ uname -mrsv
HP-UX B.11.31 U ia64
 
I compiled FreeTDS with the following gcc configuration...
 
/usr/local/freetds/bin (dolphin) $ gcc -v
Using built-in specs.
Target: ia64-hp-hpux11.23
Configured with: /tmp/gcc-4.3.1.tar.gz/gcc-4.3.1/configure
--host=ia64-hp-hpux11.23 
 --target=ia64-hp-hpux11.23 --build=ia64-hp-hpux11.23
--prefix=/opt/hp-gcc-4.3.1 
 --with-gnu-as --without-gnu-ld --with-ld=/usr/ccs/bin/ld
--enable-threads=posix 
 --enable-languages=c,c++ --with-gmp=/proj/opensrc/be/ia64-hp-hpux11.23 
 --with-mpfr=/proj/opensrc/be/ia64-hp-hpux11.23
Thread model: posix
gcc version 4.3.1 (GCC)
/usr/local/freetds/bin (dolphin) $
 
Any assitance would be greatly appreciated.  
 
Thanks in advance!
 
 
 
 



More information about the FreeTDS mailing list