[freetds] freetds 0.82 and unixodbc 2.2.14 on a Shared Linux Host

Robert Kenyon rob at digsoldev.net
Fri May 1 11:34:34 EDT 2009


Update:

I successfully replaced unixODBC with iodbc and had no troubles
finding the iodbc headers and compiling a functional freetdsodbc
driver.

Bummer as iodbc seems to be a bit stale.  Does anyone know if I'm
giving up any important functionality going to iodbc?

Rob

On Wed, Apr 29, 2009 at 9:58 AM, Robert Kenyon <rob at digsoldev.net> wrote:
> Are there any known issues with these release versions when installed
> on a shared linux host (no root, must use prefix to build).
> The problem I'm running into is that freetds will not find the
> unixodbc include files.
> unixodbc was configured thusly:
> ./configure --prefix=$HOME/local/unixodbc --enable-gui=no
> and seemed healthy.  $HOME/local/unixodbc has four directories
> including include and lib
> freetds 0,82 didn't configure so well.
> ./configure --prefix=$HOME/local/freetds --with-tdsver=8.0
> installed and connected to the db fine with tsql but didn't build a
> libtdsodbc.so (Understandble as unixodbc was not installed in a normal
> place)
>
> So, I went back and tried:
>
> ./configure --prefix=$HOME/local/freetds --with-tdsver=8.0
> --with-unixodbc=$HOME/local/unixodbc
>
> This seems like it should be right based on all the info I've seen -
> although most people have it in the "normal" places - but configure
> fails saying it can't find sql.h.
>
> So I tried
> ./configure --prefix=$HOME/local/freetds --with-tdsver=8.0
> --with-odbc_nodm=$HOME/local/unixodbc
>
> and
>
> ./configure --prefix=$HOME/local/freetds --with-tdsver=8.0
> --with-odbc-nodm=$HOME/local/unixodbc/include
>
> (as there were some recent discussions over what with-odbc-nodm
> pointed to on the list)
>
> Both of these fail in the same way - reporting that it cannot find sql.h
>
> It sure seems like it should be working - although all the docs I'm
> seeing for unixodbc indicates support for the previous 0.6x release.
>
> Any ideas?
>
> Rob
>



More information about the FreeTDS mailing list