[freetds] ./configure error on OSX 10.5.4

John Turk johnt at tvw.org
Tue Aug 12 14:18:20 EDT 2008


Hi everybody. I hope this question isn't totally noobified. I am  
having troubles with FreeTDS when I run configure on OSX. I Googled  
and searched through the FAQ, but didn't see anything pertaining to  
this. It tells me that the C compiler can't create executables. I  
tried running it as root to see if it was some funky permissions  
problem, but it doesn't seem to help. I even tried just straight ./ 
configure without passing any options to it. As a side note, I've  
never really tried to compile anything on this system manually before.


./configure --with-iodbc=/usr --with-mssql=shared,/usr/local/freetds -- 
with-apxs
checking for a BSD-compatible install... /usr/bin/install -c
checking whether build environment is sane... yes
checking for gawk... no
checking for mawk... no
checking for nawk... no
checking for awk... awk
checking whether make sets $(MAKE)... yes
checking build system type... i686-apple-darwin9.4.0
checking host system type... i686-apple-darwin9.4.0
checking for style of include used by make... GNU
checking for gcc... gcc
checking for C compiler default output file name... configure: error:  
C compiler cannot create executables
See `config.log' for more details.


Here's what I saw in the 'config.log' file that looked important.

...
configure:2501: checking for C compiler default output file name
configure:2504: gcc    conftest.c  >&5
/usr/bin/ld: /usr/lib/gcc/i686-apple-darwin8/4.0.1/../../../ 
libSystem.dylib unknown flags (type) of s$
collect2: ld returned 1 exit status
configure:2507: $? = 1
configure: failed program was:
| /* confdefs.h.  */
...

Thanks in advance...

John



More information about the FreeTDS mailing list