[freetds] Unable to install to AIX 5.2

Martin Mann mmann at otmltd.com
Tue Jun 10 13:12:30 EDT 2008


Hiya...

I have been asked to install freetds-0.82 on our AIX 5.2 development server in order to access MS SQL servers using Perl and have run into problems.

The configure runs fine but the make falls over with the following;

---------Start Quote ----------------------------------------------------------------
Target "all" is up to date.
        if gcc -DHAVE_CONFIG_H -I. -I. -I../../include  -I../../include   -D_FREETDS_LIBRARY_SOURCE -D_REENTRANT -D_THREAD_SAFE -DDEBUG=1 -Wall -Wstri
ct-prototypes -Wmissing-prototypes -Wno-long-long -D_THREAD_SAFE  -g -O2 -MT tsql.o -MD -MP -MF ".deps/tsql.Tpo" -c -o tsql.o tsql.c;  then mv -f ".de
ps/tsql.Tpo" ".deps/tsql.Po"; else rm -f ".deps/tsql.Tpo"; exit 1; fi
        /bin/sh ../../libtool --tag=CC --mode=link gcc -D_THREAD_SAFE  -g -O2    -o tsql  tsql.o ../tds/libtds.la  ../replacements/libreplacements.la 
  -liconv   -lpthreads 
mkdir .libs
gcc -D_THREAD_SAFE -g -O2 -o tsql tsql.o  ../tds/.libs/libtds.a ../replacements/.libs/libreplacements.a -liconv -lpthreads
        if gcc -DHAVE_CONFIG_H -I. -I. -I../../include  -I../../include   -D_FREETDS_LIBRARY_SOURCE -D_REENTRANT -D_THREAD_SAFE -DDEBUG=1 -Wall -Wstri
ct-prototypes -Wmissing-prototypes -Wno-long-long -D_THREAD_SAFE  -g -O2 -MT freebcp.o -MD -MP -MF ".deps/freebcp.Tpo" -c -o freebcp.o freebcp.c;  the
n mv -f ".deps/freebcp.Tpo" ".deps/freebcp.Po"; else rm -f ".deps/freebcp.Tpo"; exit 1; fi
        /bin/sh ../../libtool --tag=CC --mode=link gcc -D_THREAD_SAFE  -g -O2    -o freebcp  freebcp.o ../dblib/libsybdb.la  -lpthreads 
gcc -D_THREAD_SAFE -g -O2 -o .libs/freebcp freebcp.o  -L../dblib/.libs -lsybdb -liconv -lpthreads -Wl,-blibpath:/usr/local/lib:/usr/local/lib/gcc-lib/
powerpc-ibm-aix5.2.0.0/3.3.2:/usr/local/lib/gcc-lib/powerpc-ibm-aix5.2.0.0/3.3.2/../../..:/usr/lib:/lib 
ld: 0711-317 ERROR: Undefined symbol: .tdsdump_open
ld: 0711-345 Use the -bloadmap or -bnoquiet option to obtain more information.
collect2: ld returned 8 exit status
make: 1254-004 The error code from the last command is 1.


Stop.
make: 1254-004 The error code from the last command is 1.
---------End Quote ------------------------------------------------------

Any advice would be appreciated. I have tried surfing for some answers and found a few things but they seem to be for earlier versions so the fixes may be close but not what I need. 

I've seen the comments in the documentation regarding AIX;

---------Start Quote ----------------------------------------------------------------------
AIX®
AIX® can induce linker indigestion. libtool doesn't always understand that a .a file can be a shared library. One solution is to build only static libraries with the --disable-shared configure option. 

Another problem seems to be that the linker isn't asked to pull in all the requisite libraries.
---------End Quote ---------------------------------------------------------------------- 

Sorry if this is a dumb question but is turning on the --disable-shared a big deal for out developers?

This suggested reading the following which seemed close but I cant find the line to modify so I'm guessing it has changed since version 0.63...

---------Start Quote ----------------------------------------------------------------------

[freetds] MSSQL on AIX 5.1
Frédéric Le Guillou frederic.leguillou at cegedim.fr 
Mon Aug 9 07:15:19 EDT 2004 

Previous message: [freetds] FreeTDS 0.63 and OpenOffice 
Next message: [freetds] Inserting empty strings into MS SQL Server 
Messages sorted by: [ date ] [ thread ] [ subject ] [ author ]

Hi All,

I was reading the forum about MS SQL and AIX 5.1.
I was trying to compile FreeTDS on AIX 5.2, and the same error occurs.

I fix the problem to add "../tds/libtds_objects.la -liconv
../replacements/libreplacements.*" at the end of the line of " bin/sh
../../libtool --mode=link gcc  -g -O2", which preceding the ld error.

In fact, the problem occurs dunring the link of apps, and pool.

In fact, all the symbols needed (tds_connect, ....) are declared in
../tds/libtds_objects.la.

I hope it will be useful for your problem on AIX 5.1

Thanks,
Frédéric

---------End Quote ----------------------------------------------------------------------

Martin Mann


This e-mail and its attachments are confidential and intended solely for the addressee. If you are not the intended addressee, you must not disclose, forward, copy or take any action in respect of this email or any attachments. If you have received this e-mail in error, please delete it and notify the sender. While OTM have taken every reasonable precaution to minimise this risk, we cannot accept liability for any damage, which you may sustain as a result of software viruses. You should carry out your own virus checks before opening the attachment. 
Opus Trust Marketing Limited, 133 Scudamore Road, Braunstone Frith Industrial Estate, Leicester, LE3 1UQ
Registered in England, Number 3829642




More information about the FreeTDS mailing list