[freetds] cspublic.h BLK_VERSION_XXX - should this patch be applied?

James K. Lowden jklowden at freetds.org
Fri May 30 17:52:02 EDT 2008


Reid, Roger L. wrote:
> 
> I modified include/cspublic.h so that sqsh-2.1.5 would compile with
> 0.82.   In March,
> http://lists.ibiblio.org/pipermail/freetds/2008q1/023098.html dealt with
> about the same issue  (except not including Sybase 15) by putting the
> defines in the sqsh code instead.
> 
> I have only tested this on Solaris 8.  
> 
> ----------- diff -e cspublic.h.orig cspublic.h -----------------
> 449c
> #define BLK_VERSION_110 BLK_VERSION_100
> #define BLK_VERSION_110 BLK_VERSION_100
> #define BLK_VERSION_120 BLK_VERSION_100
> #define BLK_VERSION_125 CS_VERSION_125
> #define BLK_VERSION_150 CS_VERSION_150

Harrumph!  I applied a patch from Richard Brown to the 0.82 branch in CVS
on 19 May 2008.  I don't know why I didn't apply it to HEAD, too.  Sorry
about that, Chief.  

I applied the same patch to CVS HEAD just now.  At least we can put that
issue to bed.  

Thanks for the tickle.  

--jkl



More information about the FreeTDS mailing list