[freetds] Problems with isql

Igor igorhmm at gmail.com
Thu May 8 21:17:40 EDT 2008


Hello all,

I'm trying to get unixODBC + freeTDS on my FreeBSD 6.2 (pfSense -
developer edition).

I already get this working on another linux box.. runing with SuSE.

I've installed:
- unixODBC-2.2.12
- freetds-0.65.dev.20061107
  (I've installed this versions because I get this working fine)

The error:

[root at bsd /usr/local/etc]# isql -v LekkusLOJA $DBUSER $DBPASS
[S1000][unixODBC][FreeTDS][SQL Server]Unable to connect to data source
[ISQL]ERROR: Could not SQLConnect
[root at bsd /usr/local/etc]#

And my files:

[root at bsd /usr/local/etc]# ls -l odbc.ini odbcinst.ini freetds.conf
-rw-r--r--  1 root  wheel  188 May  8 21:48 freetds.conf
-rw-r--r--  1 root  wheel  138 May  8 21:46 odbc.ini
-rw-r--r--  1 root  wheel  188 May  8 21:47 odbcinst.ini

[root at bsd /usr/local/etc]# cat odbc.ini
[LekkusLOJA]
Driver = FreeTDS
Description = Lekkus LOJA
Trace = No
Server = 192.168.1.21
Port = 1401
TDS_version = 8.0
Database = Lekkus

[root at bsd /usr/local/etc]# cat odbcinst.ini
[FreeTDS]
Description = FreeTDS ODBC Driver for MS-SQL
Driver = /usr/local/lib/libtdsodbc.so
UsageCount = 1
[ODBC]
Trace = Yes
TraceFile = /tmp/sql.log
ForceTrace = No
Pooling = Yes

[root at bsd /usr/local/etc]# cat freetds.conf
[global]
tds version = 4.2
debug flags = 0x80
text size = 64512
[192.168.1.21]
host = 192.168.1.21
port = 1401
tds version = 8.0
dump file = /tmp/freetds.log
debug flags = 0x80

(attached is my sql.log)

I guess the 'tsql' isn't founding the correctly config from
freetds.conf... because I've tried to remove freetds.conf and I got
the same error.

Thanks for any help or tips..

Regards,

Igor
-------------- next part --------------
A non-text attachment was scrubbed...
Name: sql.log
Type: application/octet-stream
Size: 2119 bytes
Desc: not available
Url : http://lists.ibiblio.org/pipermail/freetds/attachments/20080508/d1a7f47f/attachment.obj 


More information about the FreeTDS mailing list