[freetds] isql error when connecting with SYBASE using unixODBC

shiv kumar shivblore2000 at gmail.com
Wed Sep 20 09:16:27 EDT 2006


I have installed the FreeTDS(0.63 ) and Unix ODBC(2.2.11) over our Solaris
machine. When I tried to connect the SYBASE server using isql, it is
throwing me the following error.  I have tried with various user name and
password but no of use. At the same time I am able connect successfully from
the Windows using the Sybase native driver. Please not that I am passing
the correct user name and password.



ask at logan:bin> isql -v

[IM010][unixODBC][Driver Manager]Data source name too long

[ISQL]ERROR: Could not SQLConnect

ask at logan:bin> isql -v SAS

[IM002][unixODBC][Driver Manager]Data source name not found, and no default
driver specified

[ISQL]ERROR: Could not SQLConnect

ask at logan:bin> isql -v SASA system system

src/tds/login.c: tds_connect: 72.25.8.135:4100: Connection timed out

[S1000][unixODBC][FreeTDS][SQL Server]Unable to connect to data source

[08S01][unixODBC][FreeTDS][SQL Server]Server is unavailable or does not
exist.

[ISQL]ERROR: Could not SQLConnect

*ask at logan:bin> isql -v SASA system system*

*[S1000][unixODBC][FreeTDS][SQL Server]Unable to connect to data source*

*[28000][unixODBC][FreeTDS][SQL Server]Login incorrect.*

*[08S01][unixODBC][FreeTDS][SQL Server]Read from SQL server failed.*

*[ISQL]ERROR: Could not SQLConnect*



ask at logan:UODBC> cat ./etc/odbc*.ini

[SASA]

Driver          = FreeTDS

Description             = Test Sybase Database with FreeTDS

Trace           = No

Server          = 172.25.8.135

Port            = 4100

TDS Version      = 5.0

Database                = shiv_1



[FreeTDS]

Description             = v0.63 with protocol v8.0

Driver          = /export/home/ask/TDS/lib/libtdsodbc.so

UsageCount              = 1



ask at logan:UODBC>



Thanks,

Shiva



More information about the FreeTDS mailing list