[freetds] Strange failure with apache+DBD::Sybase+FreeTDS

Rusty Phillips rustyp at freeshell.org
Thu Aug 25 08:43:19 EDT 2005

I'm having a bit of trouble with a very persistent error.
These are the symptoms:
1) When run from the command line, there are no problems connecting to the 
database and doing anything I'd like.
2) When run from the browser, the script dies before it even has a chance 
to open a connection log (freetds is set to log).
3) Turning off the DBI portion causes the script to work under the web 
interface, so it's definitely this that's causing the problem.  I've tried 
a lot of tests to be absolutely certain that my scripts are dying during 
the "DBH->connect" call.  Logs only list premature script failure.
4) Running from the command line as the web-user instead of as myself also 
works, so it's probably not a permission issue.

What I.ve tried:
I've tried using both DBD::ODBC+unixODBC and only using DBD::Sybase.  The 
symptoms are the same for both.

My config:
I've tried both freetds v 0.62.3 and freetds 0.63, both compiled with ODBC 
and MSSQL support. Apache v2.0.54

I'm using gentoo-linux with a vanilla 2.4 kernel under coLinux on a Duron 

I can give you any kind of logs you'd like to show exactly what kinds of 
output I'm getting if it'll help.  Let me know.

Anybody have any ideas?

More information about the FreeTDS mailing list