[freetds] Oracle Generic Connectivity: error: Record <table> has no fields. Loading failed

Erik van Wijk erik_vanwijk at hotmail.com
Mon Aug 16 04:12:46 EDT 2004


Yes,

Also I was able to get Oracle 10G and unixODBC and freeTDS working!!

After some time I understood the configuration better.
- I used a freedts.conf free setup of ODBC.ini
- compiled freedts   freetds-0.63.dev.20040811  with:
./configure --prefix=/appl/freetds --with-tdsver=4.2 
--with-unixodbc=/appl/unixODBC --enable-developing"

When I added "TDS_Version     = 8.0" to odbc.ini of unixODBC it all worked!!
(Using Sql server 2000 )

Probably using configure --with-tdsver=8.0 was a better option.

Later I got problems again: Reading data from an uniqueidentifier leads in 
Oracle to:  ORA-00942
Table or view does not exist. Casting the uniqueidentifier solved the 
problem.
( Created a view on the table in sql sever which did the casing: 
CAST(<uniqueidentifier> AS varchar(36)) )

Many thanks to the FreeTDS team from me too.


Jeff




>From: Jeff Fisher <JFisher at Emery-Waterhouse.com>
>Reply-To: FreeTDS Development Group <freetds at lists.ibiblio.org>
>To: 'FreeTDS Development Group' <freetds at lists.ibiblio.org>
>Subject: RE: [freetds] Oracle Generic Connectivity: error: Record <table> 
>has no fields. Loading failed
>Date: Fri, 13 Aug 2004 09:53:37 -0400
>
>This does work!  Many thanks to the FreeTDS team.
>
>Jeff
>
>-----Original Message-----
>From: ZIGLIO, Frediano, VF-IT [mailto:Frediano.Ziglio at vodafone.com]
>Sent: Friday, August 13, 2004 4:17 AM
>To: FreeTDS Development Group
>Subject: RE: [freetds] Oracle Generic Connectivity: error: Record
><table> has no fields. Loading failed
>
>
> >
> > We tried and tried to get this to work.  There is something
> > about 10g that's
> > different.  As a work around, I loaded the jtds driver into
> > Oracle and then
> > created java stored procedures to duplicate most of the
> > functionality.  This
> > doesn't help with pass through SQL, but it might solve your problem.
> >
> > As a side note, we tested the trial version of the DataDirect
> > ODBC driver
> > and it was successful with 10g.  However the cost is so
> > outrageous that we
> > are looking at plan C.
> >
>
>Today I got a report (from Jun Chen) which tell tell current CVS works
>with 10g... after disabling logs (unixODBC and FreeTDS) all it's
>working...
>
>freddy77
>_______________________________________________
>FreeTDS mailing list
>FreeTDS at lists.ibiblio.org
>http://lists.ibiblio.org/mailman/listinfo/freetds
>_______________________________________________
>FreeTDS mailing list
>FreeTDS at lists.ibiblio.org
>http://lists.ibiblio.org/mailman/listinfo/freetds

_________________________________________________________________
Play online games with your friends with MSN Messenger 
http://messenger.msn.nl/




More information about the FreeTDS mailing list