[freetds] Oracle Generic Connectivity: error: Record <table> has no fields. Loading failed

Jeff Fisher JFisher at Emery-Waterhouse.com
Thu Aug 12 08:09:53 EDT 2004


We tried and tried to get this to work.  There is something about 10g that's
different.  As a work around, I loaded the jtds driver into Oracle and then
created java stored procedures to duplicate most of the functionality.  This
doesn't help with pass through SQL, but it might solve your problem.

As a side note, we tested the trial version of the DataDirect ODBC driver
and it was successful with 10g.  However the cost is so outrageous that we
are looking at plan C.

-----Original Message-----
From: Erik van Wijk [mailto:erik_vanwijk at hotmail.com]
Sent: Thursday, August 12, 2004 4:20 AM
To: freetds at lists.ibiblio.org
Subject: [freetds] Oracle Generic Connectivity: error: Record <table>
has no fields. Loading failed


We are running Solaris 5.8 and Oracle 10g
We are trying to set up a connection to a MS SQLSERVER using freetds and 
unixODBC

Testen the connection to the MS SQLSERVER database with isql and tsql are 
all fine
So setup of freetds and unixODBC must be OK.

In the oracle database we get the next error:

select * from "MIES"@kana
              *
ERROR at line 1:
ORA-00942: table or view does not exist
[Generic Connectivity Using ODBC]Record MIES has no fields. Loading failed
ORA-02063: preceding 2 lines from KANA

freetds version tested:
- 0.62.4
- freetds-0.63.dev.20040811 with configure --enable-developing as suggested 
somewhere

has someone siolved this issue?

_________________________________________________________________
MSN Search, for accurate results! http://search.msn.nl

_______________________________________________
FreeTDS mailing list
FreeTDS at lists.ibiblio.org
http://lists.ibiblio.org/mailman/listinfo/freetds



More information about the FreeTDS mailing list