[freetds] [RE] libtdsodbc is missing

Konstantin Poltev kokach at ut.ee
Fri Jul 30 04:00:27 EDT 2004


Hello Patrick,

I could not even have imagened ever, that the maitainer of iODBC would be
helping me, it is a big honour for me.

I have almost managed with the problem. Yes, everything is ok with the
package of iODBC as well as with the package of FreeTDS. It's all about my
crooked hands - iODBC was not even installed on the server, I mean I
uninstalled it accidentally, that's why I could not find libtdsodbc.so. So
it's not more the problem with the libtdsidbc, but I am still a lamer in
connecting Linux to MSSQL server, so I would be very grateful, if you
could help me with the rest I could not find anywhere.

The problem appears when I am trying to test ODBC connection using
iodbctest utility. It prints next message:
1: [FreeTDS][SQL Server]Could not find UID parameter (0), SQLSTATE=IM007
But UID is in there! I mean I wrote it in the odbc.ini.
This is the thing, I wrote to odbc.ini:

[MyServer70]
Driver       = /usr/local/lib/libtdsodbc.so
Description  = MSSQL Server 7.0
Trace        = No
Servername   = MyServer70 //I am not sure with it, I just wrote the same
Database     = veebaas    //name, as the Data Source
UID          = sa  //This one is not completely clear for me too, should it
                   //be the UID of user, who connects

> Hi Konstantin,
>
>
>> I would like to thank you for having such interest in my problem.
>> However,
>> it is still not solved. About my target - in our company there is a
>> MSSQL
>> server under Windows XP. Our boss wants to have Perl scripts on our
>> web-server under Slackware Linux 9.1 to be connected to the MSSQL
>> server,
>> that our clients could receive some vital information from the database.
>> And I have to do it.
>> About ./configure e.t.c. - I am doing this with --with-iodbc and still
>> can
>> not find libtdsodbc. I even tried to download another version of
>> freetds,
>> not the latest one, but did receive the same answer... I have heard,
>> that
>> some rpm's can help, but even this can not be in use for me, because
>> rpm's
>> don't want to work normally on my server. They always find some kind of
>> dependencies, such as bin/sh, which have to be already installed...
>> I just installed iodbc, after that I've made standard
>> tar xvzf freetds-stable.tar.gz
>> cd freetds-stable
>> ./configure --prefix=/usr/local (or even without prefix)
>> --with-iodbc=/usr/local
>> gmake
>> gmake install
>>
>> What could I do wrong.
>> I am/will be very grateful for your help.
>>
>> PS. I beg your pardon for my bad English, unfortunately I do not have
>> opportunity to practice it.
>
> As maintainer of iODBC i would like to help you get FreeTDS and iODBC to
> work on your machine. I have checked the code and it should be working,
> but there could be a small difference between my installation and yours.
>
> Can you tell me the exact versions of iODBC and FreeTDS archive you are
> using.
>
> Also can you send me the config.log file of both your iODBC installation
> and your FreeTDS installation. This should contain enough information
> for me to diagnose what is going on.
>
>
> Best regards,
>
> Patrick
> --
> Patrick van Kleef            Email : <iodbc at openlinksw.com>
> Maintainer iODBC             Web   : <http://www.iodbc.com>
> OpenLink Software
>
> Universal Data Access & Data Integration Technology Providers
>





More information about the FreeTDS mailing list