[freetds] RE: Bug in SQLNumResultCol function?

jun_chen at bankone.com jun_chen at bankone.com
Fri Jul 23 09:20:44 EDT 2004


freddy77,

I replied your email a few weeks ago. Then I went for vacation. After I 
came back from vacation, I found out the email got rejected by the list
because of the size of the attached log file. Very sorry about that.

I did that again from the beginning by downloading freetds 0.63 from 7/22 
build.

I changed odbcinst.ini as you suggested and also added the following two 
lines to freetds.conf:
        dump file = /tmp/freetds.log
        debug level = 10

After I run the sql command select * from "scProblem"@msticket in Oracle 
sqlplus, I got the attached SQL log file:



Oracle support verified the connection was setup correctly. I can run 
select * from all_catalog at msticket 
and select * from dual at msticket successfully.

Thanks.

Jun

> freddy77,
> 
> After I did ./configure --prefix=/usr/local/freetds 
> --with-unixodbc=/usr/local/unixODBC as you suggested with the 
> following 
> configuration in /etc/odbcinst.ini
> 
> [TDS]
> Description     = FreeTDS v0.63
> Driver          = /usr/local/freetds/lib/libtdsodbc.so
> Setup           = /usr/local/freetds/lib/libtdsodbc.so
> FileUsage       = 1
> Trace           = Yes
> TraceFile       = /tmp/sql.log
> 

Section for trace settings should be ODBC, I think your odbcinst.ini
should be

[TDS]
Description     = FreeTDS v0.63
Driver          = /usr/local/freetds/lib/libtdsodbc.so
Setup           = /usr/local/freetds/lib/libtdsodbc.so
FileUsage       = 1

[ODBC]
Trace           = Yes
TraceFile       = /tmp/sql.log
ForceTrace      = Yes
Pooling         = No

> and /etc/odbc.ini
> 
> [peregrine]
> Description     = Peregrine MS SQL Server
> Driver          = TDS
> Servername      = peregrine
> Trace           = Yes
> TraceFile       = /tmp/sql.log
> ForceTrace      = Yes
> Pooling         = No
> 
> the command isql -v peregrine <username> <password> works fine.
> But the database link msticket in oracle to the MS SQL server 
> peregrine 
> still doesn't work. I run select * from "scProblem"@msticket 
> in Oracle 
> SQLPLUS
> and got the error:
> select * from "scProblem"@msticket
>               *
> ERROR at line 1:
> ORA-02068: following severe error from MSTICKET
> ORA-28511: lost RPC connection to heterogeneous remote agent 
> using SID=%s
> ORA-28509: unable to establish a connection to non-Oracle system
> 

Mmmm... I don't know Oracle, are you sure connection is set ok?

> The log sql.log didn't get created. I also did export 
> TDSDUMP=/admin/home/oracle/freetds.log and the file 
> freetds.log is empty.

It seems FreeTDS it's not trying to connect...

> I also turned on trace on the database link. Here is the trace from 
> Oracle.
> 

It's not clear to me. Try changing odbcinst.ini as specified.

freddy77

This transmission may contain information that is privileged, confidential and/or exempt from disclosure under applicable law. If you are not the intended recipient, you are hereby notified that any disclosure, copying, distribution, or use of the information contained herein (including any reliance thereon) is STRICTLY PROHIBITED. If you received this transmission in error, please immediately contact the sender and destroy the material in its entirety, whether in electronic or hard copy format. Thank you.



More information about the FreeTDS mailing list