[freetds] Help! Problems building freetds 0.62.4 on solaris9withlibreplacements.la

Matt Wisner mwisner at reachapps.com
Fri Jul 16 17:34:25 EDT 2004


James,
Thanks for responding. 

Well, between my original post and your reply I moved the FreeTds 0.62.4
package over to a Solaris8 box and did my "configure" and "make" there but
did not do a "make install" .  I then tar'd up the entire directory
structure and moved it back to my Solaris9 box where I preceded to do a
"make install".
This probably isn't a "good" way to do this but I had tried everything I
could think of and this was worth a shot.

Anyway, the "make install" back on the Sol9 box based on the files from the
"make" on the Sol8 boxed seemed to work.  "make install" completed without
errors but my "tsql" test failed. (Not sure if this because of my test or
the install...)

About this time, James, I saw your email and did a "make clean",
"configure", and "make" back on the Sol9 box as I originally tried.  Funny
thing is that "make" did not bomb on libreplacements this time. In fact,
"make" and "make install" ran just fine.  Of course, my tsql test still
failed so I'm kinda in the same boat.

>>I would like to solve the libtool problem for 0.63, though, so if you want
>>to help debug this libtool problem, that would be great.  

My alterative to getting this working is to write the TDS protocol from
scratch so it would be great for me, too.

Thanks,
Matt



-----Original Message-----
From: freetds-bounces at lists.ibiblio.org
[mailto:freetds-bounces at lists.ibiblio.org] On Behalf Of Lowden, James K
Sent: Friday, July 16, 2004 3:22 PM
To: FreeTDS Development Group
Subject: RE: [freetds] Help! Problems building freetds 0.62.4 on
solaris9withlibreplacements.la

> From: Matt Wisner
> Sent: July 16, 2004 2:49 PM
>
> I'm trying to build FreeTds (version 0.62.4) on solaris9.  
> Make croaks when
> it calls libtool to create libreplacements.la; bash returns "false cru 
> .libs/libreplacements.a .libs/iconv.o .libs/asprintf.o 
> .libs/vasprintf.o"

I'm not sure what's going on, but I think you're misinterpreting the message
slightly:

> /bin/bash ../../libtool --mode=link gcc  -g -O2  -L/usr/local/lib -o
> libreplacements.la   iconv.lo asprintf.lo vasprintf.lo ^M

That's the libtool call.  It outputs

> false

with no newline.  Don't know why.  Then make continues with:

> cru .libs/libreplacements.a .libs/iconv.o .libs/asprintf.o 
> .libs/vasprintf.o^M

and cru(1) returns an error, probably stemming from the prior anomaly.  

> make: *** [libreplacements.la] Error 1^M

You might try:

$ cd src/replacements
$ /bin/bash -x ../../libtool \
	--mode=link gcc  -g -O2  -L/usr/local/lib \
	-olibreplacements.la   \
	iconv.lo asprintf.lo vasprintf.lo

That might make clearer what it is about the libtool script that Solaris 9
dislikes.  

Alternatively, unless you need 0.62.4, you could try 0.62.3, which was built
with an older libtool that worked with Solaris.  (IIRC it had some minor
trouble installing the documentation, but at least it built and installed
the libraries.)  

I would like to solve the libtool problem for 0.63, though, so if you want
to help debug this libtool problem, that would be great.  

--jkl


-----------------------------------------
The information contained in this transmission may contain privileged and
confidential information and is intended only for the use of the person(s)
named above. If you are not the intended recipient, or an employee or agent
responsible for delivering this message to the intended recipient, any
review, dissemination, distribution or duplication of this communication is
strictly prohibited. If you are not the intended recipient, please contact
the sender immediately by reply e-mail and destroy all copies of the
original message. Please note that we do not accept account orders and/or
instructions by e-mail, and therefore will not be responsible for carrying
out such orders and/or instructions.
If you, as the intended recipient of this message, the purpose of which is
to inform and update our clients, prospects and consultants of developments
relating to our services and products, would not like to receive further
e-mail correspondence from the sender, please "reply" to the sender
indicating your wishes.  In the U.S.: 1345 Avenue of the Americas, New York,
NY 10105.


_______________________________________________
FreeTDS mailing list
FreeTDS at lists.ibiblio.org
http://lists.ibiblio.org/mailman/listinfo/freetds





More information about the FreeTDS mailing list