[freetds] tsql problem

kevin bartz kbartz at loyaltymatrix.com
Fri Jun 18 17:48:26 EDT 2004


Thanks so much for your help, Nick! That worked well for me. By the way, I'm
using SuSE Linux with Bash. Anyway, now when I run tsql, I get a new
problem:

kevin at redtail:~/test> tsql
tsql: relocation error: /usr/local/lib/libreadline.so.4: undefined symbol:
BC

Any ideas what might be messing me up here? I've read that usually, when
this problem occurs, it has to do with ncurses not being installed. But it
is installed!

kevin at redtail:~/test> rpm -qa | grep curses
ncurses-5.3-122
ncurses-devel-32bit-9.0-0
ncurses-32bit-9.0-0
yast2-ncurses-2.8.20-57
ncurses-devel-5.3-122

Here's a look at all the readline libs sitting around in /usr/local/lib:

kevin at redtail:~/test> ls -la /usr/local/lib/libreadline*
-rw-r--r--    1 root     root       833300 2004-06-03 14:11
/usr/local/lib/libreadline.a
-rw-r--r--    1 root     root       833300 2004-06-03 13:49
/usr/local/lib/libreadline.old
lrwxrwxrwx    1 root     root           18 2004-06-03 14:11
/usr/local/lib/libreadline.so -> libreadline.so.4.3
lrwxrwxrwx    1 root     root           37 2004-06-18 14:44
/usr/local/lib/libreadline.so.4 -> /usr/local/lib/libreadline.so.4.3.old
-rw-r--r--    1 root     root       441146 2004-06-03 14:11
/usr/local/lib/libreadline.so.4.3
-rw-r--r--    1 root     root       441146 2004-06-03 13:49
/usr/local/lib/libreadline.so.4.3.old

As a quick note, I tried relinking libreadline.so.4 to each of the other
libreadline files, but all gave similar errors.

Is there something I should reinstall, or anything I can do? Thanks for all
your help.

Kevin

-----Original Message-----
From: freetds-bounces at lists.ibiblio.org
[mailto:freetds-bounces at lists.ibiblio.org] On Behalf Of Nick Stoughton
Sent: Friday, June 18, 2004 2:21 PM
To: FreeTDS Development Group
Subject: Re: [freetds] tsql problem

On Fri, 2004-06-18 at 13:40, kevin bartz wrote:
> Hi. I'm having a problem with tsql. Running it, no matter the arguments, I
> get
> 
>  
> 
> kevin at redtail:~/test> tsql
> 
> tsql: error while loading shared libraries: libtds.so.3: cannot open
shared
> object file: No such file or directory
> 
What OS? Linux?

>  
> 
> ldd gives
> 
>  
> 
> kevin at redtail:~/test> ldd /usr/local/bin/tsql
> 
>         libreadline.so.4 => /usr/local/lib/libreadline.so.4
> (0x0000002a9566d000)
> 
>         libtds.so.3 => not found
> 
>         libc.so.6 => /lib64/libc.so.6 (0x0000002a957a5000)
> 
>         /lib64/ld-linux-x86-64.so.2 => /lib64/ld-linux-x86-64.so.2
> (0x0000002a95556000)
> 
EITHER: set your environment variable LD_LIBRARY_PATH to include
/usr/local/lib
	(Bash): export LD_LIBRARY_PATH=/usr/local/lib:$LD_LIBRARY_PATH

OR: (as root) set it permanently in your ld.so.conf file by
	/sbin/ldconfig -n /usr/local/lib
(assumes a GNU/Linux OS)
>  
> 
> The funny thing is, libtds.so.3 is in /usr/local/lib with everything else.


-- 
Nick Stoughton <nick at msbit.com>

_______________________________________________
FreeTDS mailing list
FreeTDS at lists.ibiblio.org
http://lists.ibiblio.org/mailman/listinfo/freetds





More information about the FreeTDS mailing list