[freetds] RE: Bug in SQLNumResultCol function?

jun_chen at bankone.com jun_chen at bankone.com
Mon Jun 14 15:19:10 EDT 2004


freddy77,

After I did ./configure --prefix=/usr/local/freetds 
--with-unixodbc=/usr/local/unixODBC as you suggested with the following 
configuration in /etc/odbcinst.ini

[TDS]
Description     = FreeTDS v0.63
Driver          = /usr/local/freetds/lib/libtdsodbc.so
Setup           = /usr/local/freetds/lib/libtdsodbc.so
FileUsage       = 1
Trace           = Yes
TraceFile       = /tmp/sql.log

and /etc/odbc.ini

[peregrine]
Description     = Peregrine MS SQL Server
Driver          = TDS
Servername      = peregrine
Trace           = Yes
TraceFile       = /tmp/sql.log
ForceTrace      = Yes
Pooling         = No
 
the command isql -v peregrine <username> <password> works fine.
But the database link msticket in oracle to the MS SQL server peregrine 
still doesn't work. I run select * from "scProblem"@msticket in Oracle 
SQLPLUS
and got the error:
select * from "scProblem"@msticket
              *
ERROR at line 1:
ORA-02068: following severe error from MSTICKET
ORA-28511: lost RPC connection to heterogeneous remote agent using SID=%s
ORA-28509: unable to establish a connection to non-Oracle system

The log sql.log didn't get created. I also did export 
TDSDUMP=/admin/home/oracle/freetds.log and the file freetds.log is empty.
I also turned on trace on the database link. Here is the trace from 
Oracle.



Thanks a lot for your help.

Jun




Il ven, 2004-06-11 alle 15:07, jun_chen at bankone.com ha scritto:
> Thanks a lot, freddy77.
> 
> I downloaded the unstable version 0.63 today. Which library file should 
I 
> use
> in the odbcinst.ini? I tried almost all of them in the lib directory, 
such 
>  as libsybdb.so,
> libtdssrv.so, libtds.so, and libct.so.

???

odbcinst.ini contains informations about drivers installed and other
options.
My odbcinst.ini contains

[FreeTDS]
Description             = FreeTDS
Driver          =
/home/freddy/cpp/freetds/freetds/src/odbc/.libs/libtdsodbc.so
Setup           =
/home/freddy/cpp/freetds/freetds/src/odbc/.libs/libtdsodbc.so
FileUsage               = 1
Trace           = Yes
TraceFile               = /tmp/sql.log
 
[ODBC]
Trace           = Yes
TraceFile               = /tmp/sql.log
ForceTrace              = Yes
Pooling         = No


Note that odbcinst.ini do not contains entry for servers.


> When I tried to use the unixodbc command isql -v peregrine <username> 
> <password>, it always got
> the error:
> [IM004][unixODBC][Driver Manager]Driver's SQLAllocHandle on 
> SQL_HANDLE_HENV failed
> [ISQL]ERROR: Could not SQLConnect
> 
> Jun
> 

freddy77




------------------------------

_______________________________________________
FreeTDS mailing list
FreeTDS at lists.ibiblio.org
http://lists.ibiblio.org/mailman/listinfo/freetds


End of FreeTDS Digest, Vol 17, Issue 16
***************************************




This transmission may contain information that is privileged, confidential and/or exempt from disclosure under applicable law. If you are not the intended recipient, you are hereby notified that any disclosure, copying, distribution, or use of the information contained herein (including any reliance thereon) is STRICTLY PROHIBITED. If you received this transmission in error, please immediately contact the sender and destroy the material in its entirety, whether in electronic or hard copy format. Thank you.

-------------- next part --------------
A non-text attachment was scrubbed...
Name: msticket.trc
Type: application/octet-stream
Size: 1652 bytes
Desc: not available
Url : http://lists.ibiblio.org/pipermail/freetds/attachments/20040614/e2c172dd/attachment.obj 


More information about the FreeTDS mailing list