[freetds] Re: MSSQL error on certain Tables [php]

Robert Kruse rkruse at 2440media.com
Thu May 20 08:36:39 EDT 2004


On 5/18/04 11:10 PM, "Daniel Fazekas" <fdsubs at axelero.hu> wrote:

> 
> On May 19, 2004, at 1:37, Robert Kruse wrote:
> 
>> Through PHP, we can successfully send a simple query to 42 out of the
>> 49
>> tables, but when we try to do a simple query to any of the 7
>> outstanding
>> tables, we get the "The page cannot be displayed" error.
> 
> Any simple queries ought to work, even rather complex ones. Something's
> definitely wrong here.
> As I understand you can reliable reproduce your problem all the time.
> If so, we are off to a good start.
> 
> Let's go through some of the usual troubleshooting steps.
> 
> 1. More information
> 
>> I have FreeTDS.62 running on IRIX64 with apache2 & PHP 4.3.5 and we're
>> accessing an SQL Server 7 database with 49 tables.
> 
> - Which PHP extension are you using with FreeTDS: mssql / sybase /
> sybase_ct / odbc? [SQSH uses Ct-lib, and the only PHP extension
> accessing that interface is the sybase_ct one.]
> Is it linked in statically or loaded from a shared module?

We installed PHP with --with-mssql=/usr/local/freetds

So we're using all mssql commands in the code (ie. mssql_pconnect,
mssql_query, mssql_fetch_array).

 
> - FreeTDS configuration basics: what TDS version are you using? Is
> FreeTDS set up to do any iconv character encoding translation? (The
> latter could be the reason why some tables behave differently from the
> others.)

I've tried changing various settings in the freetds.conf file. Switching TDS
versions between both 4.2 and 7.0. Tried adding/deleting "client charset =
UTF-8". But none of the changes appeared to effect my results.

 
> - Try loading the page in another browser to see what the server really
> sends. "The page cannot be displayed" sounds like a Windows Internet
> Explorer "friendly" error message. In Microsoft speak, friendly means
> it does its best to obscure what the problem really is. Also check the
> Apache error log. I suspect a segmentation fault.

I can't seem to get a real error message. Netscape gives me a pop-up "Page
contains no data". Safari errors, "Safari can't open the page." Opera never
loads or errors.

Apache gives me:
[Wed May 19 09:20:03 2004] [notice] child pid 1028 exit signal Bus error
(10)


> 2. Set out to isolate the problem
> 
> - Start with the single most effective step: try the same php script
> using the command-line cli php interpreter to get Apache out of the
> picture. One less variable to care about. You most likely already have
> the cli version of php installed even if you aren't aware of it. In
> recent versions of PHP such as yours, it's automatically built
> alongside the Apache module.

Whenever I run a php page that works fine in the browser from cli php on the
command line it always errors "Call to undefined function:  mssql_connect()
... Segmentation fault (core dumped)". So I haven't been successful in
getting cli php to work.

Thanks for your help.

> On the whole, I suspect a 64-bit or IRIX issue somewhere.
> 
> --
> fds
> 
> _______________________________________________
> FreeTDS mailing list
> FreeTDS at lists.ibiblio.org
> http://lists.ibiblio.org/mailman/listinfo/freetds
> 




More information about the FreeTDS mailing list