[freetds] Freetds 0.60.1 vs freetds 0.62.3 and unixODBC 2.2.8

Novick, Jeff novickj at toysrus.com
Fri May 14 08:21:28 EDT 2004


Ok, it's working.
Here's what happened:

I had misspelled the database name in odbc.ini on the 'Database =' line.
0.60.1 seems to let you connect and run sql commands anyway.
0.62.3 seemed to choke on it and exit with the login failed error.

Thank you for all your help.

Jeff


-----Original Message-----
From: James K. Lowden [mailto:jklowden at schemamania.org] 
Sent: Thursday, May 13, 2004 8:10 PM
To: FreeTDS Development Group
Subject: Re: [freetds] Freetds 0.60.1 vs freetds 0.62.3 and unixODBC 2.2.8

On Thu, 13 May 2004 11:44:51 -0400, "Novick, Jeff" <novickj at toysrus.com>
wrote:
> Thank you, but, that's where freetds.conf is currently located.
> root at pollerint:~/source/freetds-0.62.3# ls -l /etc/freetds.conf
> ls: /etc/freetds.conf: No such file or directory
> 
> ls -l /usr/local/etc/freetds.conf
> -rw-r--r--    1 root     root         3663 May 13 07:21
> /usr/local/etc/freetds.conf
> 
> So I tried this, and still no good.

Try setting TDSDUMPCONFIG.  When the FreeTDS ODBC driver is called on to
look up the servername, it will log its search attempts to that file.  

Alternatively, look in your TDSDUMP log.  If it says it can't connect to
server SYBASE, it's likely freetds.conf was not consulted.  It may be that
your odbc.ini doesn't correctly reflect where FreeTDS is installed.  

HTH.

--jkl
_______________________________________________
FreeTDS mailing list
FreeTDS at lists.ibiblio.org
http://lists.ibiblio.org/mailman/listinfo/freetds

======================================================================== 
This email message is for the sole use of the intended recipient (s) and may
contain confidential and privileged information. Any unauthorized review,
use, disclosure or distribution is prohibited. If you are not the intended
recipient, please contact the sender by reply email and destroy all copies
of the original message. To reply to our email administrator directly, send
an email to EmailAdmin at toysrus.com. 
Toys "R" Us, Inc.



More information about the FreeTDS mailing list