[freetds] Help with chroot jail and FreeTDS

Deven Phillips deven at hcc.hawaii.edu
Mon Apr 19 20:57:14 EDT 2004


Hi all,

	I am using PHP 4.3.6, Apache 2.0.48, mod_security, and FreeTDS 0.62.3 on 
Linux Mandrake 10.0. My question is that, through mod_security, I am forcing 
Apache/PHP to run in a chroot jail under '/chroot'. When I run the whole 
thing in the original root it works fine. When I run it chrooted, I get an 
error about an invalid assertion and the httpd thread segfaults. I know that 
I need to get the proper files into the chroot jail, including the 
freetds.conf and pool.conf, etc.. I have done this as well as copied the 
includes, libs, docs, and everything else that I can find that freetds 
installs. What am I missing? I've even gone to the extreme of running 'ldd' 
against all of the libs and copying their dependent libs into the chroot 
(which I didn't want to do). What am I not finding here? Any ideas would be 
greatly appreciated.

Deven



More information about the FreeTDS mailing list