[freetds] Re: ASA Error -83 when connecting from PHP

Daniel L. Eriksson daniel at edeinternet.com
Wed Apr 7 18:48:12 EDT 2004


You make a good point. I tried just now, and it didn't work though.

Any other ideas anyone?

Thanks,
Daniel



At 11:58 PM 4/7/2004 +0200, Daniel Fazekas wrote:
----------------------------------------------------------------------- 


On Apr 7, 2004, at 23:36, Daniel L. Eriksson wrote:

>I have installed FreeTDS 0.62, compiled with PHP under Linux Redhat 9. 
>
>SyBase server is ASA 8.0.
>I send this command:
>sybase_connect("192.168.0.101:3030","DBA","SQL");
>And get this error:
>Sybase message: ASA Error -83: Specified database not found (severity
>16)
>I tried 'telnet 192.168.0.101 3030', which works fine. I'm also able
>to connect through ODBC to the same IP and port w/o problems.
>I read on this list that the problem could be not sending the data
>base name with the server name. Is that the problem, and if so, how do 
>
>I send it?

AFAIK, you can only switch the database after you have successfully
connected.

Your problem could be similar to what we once experienced with MS SQL
Server 2000, which most likely inherited this feature from Sybase. In
MSSQL each SQL user has a specific default database, configurable in
Enterprise Manager.  Our user's default database did exist, but we had
no access rights to it. So our connection attempts were refused
outright, even though there were several other databases that our user
had rights to -- just not to this default database. The solution was
simply to change our user's default database in MS SQL Enterprise
Manager.

--
fds

_______________________________________________
FreeTDS mailing list
FreeTDS at lists.ibiblio.org
http://lists.ibiblio.org/mailman/listinfo/freetds





More information about the FreeTDS mailing list