[freetds] libreadline.so.4.1 is needed by freetds-o.61-2.i386.rpm

Alf-Ivar Holm alfh+devnull at ifi.uio.no
Thu Jun 19 08:27:47 EDT 2003


"Arun Bayya" <akbayy2 at uky.edu> writes:

> My problem was that I failed to install freetds on RedHat 8 from the
> RPMs. I encountered :
> "error:Failed dependencies:
> Libreadline.so.4.1 is needed by freetds-0.61-2"
  ^

That 'l' is upper case.  In the filename below it is down case.

> This was in spite of the environment shown below -
> 
> > # ls -l /usr/lib/libreadline*
> > /usr/lib/libreadline.so.4.1 -> /usr/lib/libreadline.so.4.3
> > -rwxr-xr-x    1 root     root       208488 Aug  7  2002
> > /usr/lib/libreadline.so.4.3

Whoever made the RPM seems to have some odd environment, or has
another RPM called "Libreadline.so.4.1"!?  (I haven't tried
freetds-0.61-2.rpm myself.)

        Affi



More information about the FreeTDS mailing list