[freetds] libreadline.so.4.1 is needed by freetds-o.61-2.i386.rpm

Arun Bayya akbayy2 at uky.edu
Thu Jun 19 00:48:40 EDT 2003


Thanks James for your replies.

The following information is for the benefit of others who look at this
post, as suggested by James.

My problem was that I failed to install freetds on RedHat 8 from the
RPMs. I encountered :
"error:Failed dependencies:
Libreadline.so.4.1 is needed by freetds-0.61-2"

This was in spite of the environment shown below -

> # ls -l /usr/lib/libreadline*
> -rw-r--r--    1 root     root       254304 Aug  7  2002
> /usr/lib/libreadline.a
> lrwxrwxrwx    1 root     root           18 Jun 12 12:38
> /usr/lib/libreadline.so
> -> libreadline.so.4.3
> lrwxrwxrwx    1 root     root           18 Jun 12 11:53
> /usr/lib/libreadline.so.4 -> libreadline.so.4.3
> lrwxrwxrwx    1 root     root           27 Jun 18 00:12
> /usr/lib/libreadline.so.4.1 -> /usr/lib/libreadline.so.4.3
> -rwxr-xr-x    1 root     root       208488 Aug  7  2002
> /usr/lib/libreadline.so.4.3


So I chose to compile the source and now things work fine. Compiling
from the source is easy enough.

James, if you feel that I missed something here, you could post whatever
you want from our conversation.

Thanks again.
Arun.




-----Original Message-----
From: James K. Lowden [mailto:jklowden at schemamania.org] 
Sent: Wednesday, June 18, 2003 11:38 PM
To: Arun Bayya
Subject: Re: [freetds] libreadline.so.4.1 is needed by
freetds-o.61-2.i386.rpm

On Wed, 18 Jun 2003 01:37:51 -0400, "Arun Bayya" <akbayy2 at uky.edu>
wrote:
> I have iconv within Redhat 8.

OK, no problem with RH8.  

> I created a softlink "/usr/lib/libreadline.so.4.1 ->
> /usr/lib/libreadline.so.4.3" but it didn't help.

I would expect that to work.  :-( 

> I am a newbie so I don't understand  the significance of your earlier
> statements  " I'm surprised the RPM demands any particular readline.
> I'd think any would work, and in any event it's only used by tsql.  "

I mean: "tsql" is the only program in FreeTDS that benefits from
libreadline, and it makes no special demands on it.  Any version will
do,
as far as we're concerned.  The RPM is demanding libreadline.so.4.1, but
if you compiled it from source, it would work fine.  

> [root at dhcp-152-57 root]# rpm -ivh freetds-0.61-2.i386.rpm
> error: Failed dependencies:
>         libreadline.so.4.1 is needed by freetds-0.61-2
[root at dhcp-152-57
...
> # ls -l /usr/lib/libreadline*
> -rw-r--r--    1 root     root       254304 Aug  7  2002
> /usr/lib/libreadline.a
> lrwxrwxrwx    1 root     root           18 Jun 12 12:38
> /usr/lib/libreadline.so
> -> libreadline.so.4.3
> lrwxrwxrwx    1 root     root           18 Jun 12 11:53
> /usr/lib/libreadline.so.4 -> libreadline.so.4.3
> lrwxrwxrwx    1 root     root           27 Jun 18 00:12
> /usr/lib/libreadline.so.4.1 -> /usr/lib/libreadline.so.4.3
> -rwxr-xr-x    1 root     root       208488 Aug  7  2002
> /usr/lib/libreadline.so.4.3

That all looks good to me, Arun.  Unfortunately.  I'm not an RPM guy,
you
see.  

I answered you offlist in error; I meant to post to the list.  I replied
again offlist because I didn't want to quote your mail in public without
your say-so.  Now that we've exhausted my ideas, though, I suggest you
post a new message.  Quote the failed dependencies error, and show the
"ls
-l /usr/lib/libreadline*" output.  Ask if the RPM can be adjusted or how
it can be satisfied.  

Your better resources for this particular question may lie outside
FreeTDS, however.  Red Hat should help.  In any case, it's a pure RPM
question: how do I convince RPM that my readline is good enough ("ln -s"
seems like the right thing to me).  Or, how to go about upgrading
readline?  Something like that.  

When Frediano gets back, I think he'll be interested in your message.
He
might be able to change the RPM to be more liberal about what version of
readline it requires.  

HTH.

--jkl



-----Original Message-----
From: James K. Lowden [mailto:jklowden at schemamania.org] 
Sent: Wednesday, June 18, 2003 12:45 AM
To: Arun Bayya
Subject: Re: [freetds] libreadline.so.4.1 is needed by
freetds-o.61-2.i386.rpm

On Wed, 18 Jun 2003 00:36:36 -0400, "Arun Bayya" <akbayy2 at uky.edu>
wrote:
> When I try to install freetds on RedHat 8 from the rpms I get :
> "error:Failed dependencies:
> Libreadline.so.4.1 is needed by freetds-0.61-2"
>  
> Are there any other issues that I should take care of when installing
> freetds from rpms on RedHat 8?

You'll need iconv(3), but I assume that comes with RH8.  I'm surprised
the
RPM demands any particular readline.  I'd think any would work, and in
any
event it's only used by tsql.  

Please let us know how your fare.  

--jkl





More information about the FreeTDS mailing list