[freetds] unixODBC and FreeTDS trouble after upgrading to 0.61

Joel Apter japter at ibxtech.com
Wed Jun 11 16:38:35 EDT 2003


Thank you for your quick response.  After searching through the mailing list
archives somewhat more thoroughly I found my answer here:
http://lists.ibiblio.org/pipermail/freetds/2003q2/012505.html

However, it took me quite a while to realize this was the solution to my
problem since I was modifying my /usr/local/etc/odbc.ini file to make the
appropriate changes while my ~/.odbc.ini file was remaining unchanged (and
continued to retain to improper settings).  Little did I know that the
system first checks your ~/.odbc.ini and then /usr/local/etc/odbc.ini
(totally my fault as this is a standard method of doing things, oh well).
Hopefully this will help anyone else with a similar problem.

Also, maybe in the documentation it should be noted (in bold or something,
hehe), that .61 changed the way the servername/host variable gets passed
around between the driver and the driver manager to notify people that their
driver managers' settings must be changed after this type of upgrade
(actually, maybe I was just using strange settings that required this
modification?).  Anyways, thanks for the help...

-Joel
----- Original Message -----
From: <manoranjan_sahu at agilent.com>
To: <japter at ibxtech.com>; <freetds at lists.ibiblio.org>
Sent: Wednesday, June 11, 2003 3:38 PM
Subject: RE: [freetds] unixODBC and FreeTDS trouble after upgrading to 0.61


> I had the same problem a while back. It turned out something to do with
the configuration files.
>
> Check the freetds.conf or try setting the env variables FREETDSCONF as
documented.
>
>
> -----Original Message-----
> From: Joel Apter [mailto:japter at ibxtech.com]
> Sent: Wednesday, June 11, 2003 12:32 PM
> To: freetds at lists.ibiblio.org
> Subject: [freetds] unixODBC and FreeTDS trouble after upgrading to 0.61
>
>
> Ok, I finally upgraded to 0.61 from 0.60 (see my last post).  Installation
went smoothly, however unixODBC no longer works.  The PHP on my webserver
has no problems with database connectivity, but when I try to connect with
isql I get this:
>
> [unixODBC]Client unable to establish connection
> [ISQL]ERROR: Could not SQLConnect
>
> Looking at my log file I have this:
>
> 2003-06-11 15:07:23.029798 iconv will convert client-side data to the ""
character set
> 2003-06-11 15:07:23.030207 iconv_open: cannot convert to ""
> 2003-06-11 15:07:23.030257 IP address pointer is NULL
> 2003-06-11 15:07:23.030298 Server SYBASE not found!
>
> For some reason it looks like its getting NULL values for everything.  I
haven't changed anything in unixODBC and I copied over my backedup
freetds.conf file from 0.60.  Any ideas would be greatly appreciated.
>
> -Joel
> _______________________________________________
> FreeTDS mailing list
> FreeTDS at lists.ibiblio.org
> http://lists.ibiblio.org/mailman/listinfo/freetds
>




More information about the FreeTDS mailing list