[freetds] 0.61 tsql core dump, locale = "C C C C C C"

Cooperstock, Dan dan.cooperstock at hepcoe.com
Fri May 16 12:43:32 EDT 2003


This is what I found about INSTALL in the master Makefile:

INSTALL = /opt/imake/bin/install -c
install_sh_DATA = $(install_sh) -c -m 644
install_sh_PROGRAM = $(install_sh) -c
install_sh_SCRIPT = $(install_sh) -c
INSTALL_HEADER = $(INSTALL_DATA)

It appears that somehow "install_sh" has been substituted for INSTALL. So, I
switched it back globally in the Makefile. Then it seems to go fine, except
for the following Warning, which we've already discussed:

ld: (Warning) Unsatisfied symbol "htons" in file /usr/local/lib/libtdssrv.sl

Then, if I run tsql with no arguments, I still get the same outputs as
before - very verbose, and with the weird locale. If I try to run it with
real arguments to connect to my SQL Server, it does connect, and I can do
stuff! Yay! However, I still don't understand why it's being so verbose with
messages, like this:

in main[1]/usr/local/etc/locales.conf
Found file.
Looking for section default.
Found section default.
Got a match.
insection!
option = date format
value = %b %d %Y %I:%M%p
insection!
...

Dan Cooperstock, Senior Technical Consultant, HEPCOE Credit Union
dcoops at hepcoe.com    416-597-5055

-----Original Message-----
From: ZIGLIO Frediano [mailto:Frediano.Ziglio at mail.vodafone.it]
Sent: Friday, May 16, 2003 11:38 AM
To: FreeTDS Development Group
Subject: RE: [freetds] 0.61 tsql core dump, locale = "C C C C C C"

>
> I downloaded the nightly snapshot. When I do my configure, it ends as
> follows:
>
> finding the maximum length of command line arguments...
> ./ltconfig[790]:
> There is not enough memory available now.
> configure: error: libtool configure failed
>

Strange, we didn't touch ltconfig...

> Also, back on version 0.61, even after the relatively
> successful compile,
> I'm still getting the following error at the end of "make install":
>
>         /usr/bin/sh ./mkinstalldirs
>         if test ! -f /freetds.conf; then \
>                  ./freetds.conf /freetds.conf; \
>         fi
> sh[2]: ./freetds.conf: Execute permission denied.
>

On HP/UX 10.20 I have these 3 lines in main Makefile

INSTALL = ./install-sh -c
INSTALL_PROGRAM = ${INSTALL}
INSTALL_DATA = ${INSTALL} -m 644

It seem that your INSTALL is empty ...

> I know there was some discussion of this, but I never heard
> anything that
> would clearly fix it.
>
> BTW, I'm here the rest of today, then on vacation for 2
> weeks. I'm back in
> the office on June 2nd.
>

Have a nice holyday

bye
  freddy77



More information about the FreeTDS mailing list