[freetds] Compiling freetds 0.61 source in cygwin

Anthony Kong anthony.kong at ufjia.com
Fri Apr 25 00:21:03 EDT 2003


Hi, all,

I have tried the keyword "16 bit int" in mail arhive but does not find
anything appropriate. It seems like almost as far as back in 2001 someone
reported success in compiling TDS in sygwin. So, I would like to see if
anyone can make some suggestion to the problem I have? 

When I run ./configure, I encountered the error message:


[snip]
checking size of char...
checking for short... yes
checking size of short...
checking for long... yes
checking size of long...
checking for int... yes
checking size of int...
checking for float... yes
checking size of float...
checking for double... yes
checking size of double...
checking for long double... yes
checking size of long double...
checking for long long... yes
checking size of long long...
checking for __int64... no
checking size of __int64... 0
configure: error: No 16-bit int found.

How can I get around this problem? The version of cygwin is 

CYGWIN_NT-5.0 WS054 1.3.15(0.63/3/2) 2002-11-06 22:41 i686 unknown

"gcc -v " gives

Reading specs from /bin/../lib/gcc-lib/i686-pc-cygwin/3.2/specs
Configured with: /netrel/src/gcc-3.2-1/configure
--enable-languages=c,c++,f77,java --enable-libgcj --enable-threads=posi
x --with-system-zlib --enable-nls --without-included-gettext
--enable-interpreter --disable-sjlj-exceptions --disable-ve
rsion-specific-runtime-libs --enable-shared --build=i686-pc-linux
--host=i686-pc-cygwin --target=i686-pc-cygwin --enable
-haifa --prefix=/usr --exec-prefix=/usr --sysconfdir=/etc --libdir=/usr/lib
--includedir=/nonexistent/include --libexecd
ir=/usr/sbin
Thread model: posix
gcc version 3.2 20020818 (prerelease)


Regards,


Anthony





More information about the FreeTDS mailing list