Error connect: can't assign requested address o n DGUX

Kelly Sauke ksauke at
Fri May 11 10:54:12 EDT 2001

Thanks for the help folks.  It seems the $TDSVER trick worked.  It all of a
sudden started working yesterday and I couldn't figure out what was
different but I did indeed set the TDSVER variable about 20 minutes before.
After you mentioned that, it became clear to me what I had changed.  Now,
why does that change things on a DGUX machine, when its not needed on Linux?
They were both built with identical ./configure --with-tdsver=7.0 arguments.

Kelly Sauke

-----Original Message-----
From: James Cameron [mailto:cameron at]
Sent: Thursday, May 10, 2001 10:17 PM
To: TDS Development Group
Subject: [freetds] Re: Error connect: can't assign requested address on

Something to add for Kelly's problem after I read James Lowden's
response ...

... try that TDSVER trick, it worked for me when it should not have.

Although I had built FreeTDS identically on a Linux Intel and a Compaq
Tru64 UNIX Alpha, using --with-tdsver=4.2, the code was defaulting to
5.0 on the Alpha.

What gave it away for Brian and I was that the dump file showed a packet
stream that was longer and had the different version numbers.

So if you have one working system and one not working, set the TDSDUMP
environment variable so as to compare the two dumps?

Also consider changing the "ether" in the interfaces file to "4.2" ...
yet another way to encourage the version change.

More information about the FreeTDS mailing list