Unknown marker errors

Dmitry Petrov freetds at acorn.ru
Wed Aug 16 11:49:23 EDT 2000


The very first line in my php file on Apache web-server,
sybase_connect(...) forces server to start filling apache_error log file 
with  "Unknown marker: 0!!" lines.

I am trying to connect to Sybase SQL Anywhere Studio 7.01 (evaluation).
I installed it recently after I read on Sybase's web-site that it has 
built-in Open Server functionality. Before that I used to connect to SQL 
Anywhere 5.5 through the open server gateway and it worked (with some 

I think I tried to recompile freetds 0.50 with tdsver 4.2 and 7.0. It does 
not make any difference.

Any ideas?

Dmitry Petrov

On 07/31/00, "Steven Campbell <sammynrg at phalanx.bloor1.on.wave.home.com>" 
> Hello, i've been getting "Unknown marker: !!" and then an integer in
> both php-4.0.1pl2 compiled as an Apache 1.3.12 DSO, and sqsh-1.7 when it
> returns a large result set.
> The error message is fleshed out on line 144 in src/tds/token.c of
> today's freetds.snapshot.tgz. 
> I configured FreeTDS with "--with-tdsver=4.2 --enable-dbmfix", since I
> run it against a MS SQL 7.0 server.
> This error happens on Intel Solaris 5.8 and FreeBSD 4.0, both compiled
> with gcc-2.95.2.
> Can anybody tell me what this means, and if there is a known workaround?
> I don't think it's related, but the only errors I get when I compile
> with gcc's "-Wall" are these:
> token.c:504: warning: `tds7_process_result' was declared implicitly
> `extern' and
>  later `static'
> token.c:225: warning: previous declaration of `tds7_process_result'
> Thanks
> Steven Campbell

More information about the FreeTDS mailing list