What do these errors mean?

David MacKenzie djm at web.us.uu.net
Thu Oct 21 08:13:41 EDT 1999

I'd better followup with the answers to the natural followup questions,
before someone else asks them :-)

1. I did get sqsh working with the Sybase client libraries on the Sun, so 
the problem is FreeTDS-related.

2. I also tried the current FreeTDS snapshot (as of last night), with the 
same results as 0.47 except for the expected absence of the property 7 

3. The results seem like they're independent of the contents of my 
interfaces file.  At first I tried it using the dummy interfaces file that 
gets installed with FreeTDS.  Then I gave sqsh a -I option to use the 
interfaces file we have installed with Sybase, though that seems to have a 
somewhat different format, but sqsh didn't complain about it.  Then I wrote 
a new interfaces file using the one from FreeTDS as a guide, with just an 
entry for the server I'm trying to connect to.  I got the same error 
messages with any of those files.  But if I pointed -I to a nonexistent 
file, it did notice that and complain :-)

4. What is property 26, and where is the client getting it from if it can't 
even connect (for some reason) to the server?

5. I'm not sure which version of Sybase we're using.  It must be fairly 
recent because we did a Y2K upgrade of it this fall, but I'm not a DBA for 

Is there a way to turn on more verbose debugging?  I'm not sure what to do 

On 10/21/99, ""David MacKenzie" <djm at web.us.uu.net>" wrote:
> I'm trying to use FreeTDS 0.47 and sqsh 1.7 to access a Sybase database
running on Solaris 2.5.1.  It produces some error messages, below, that
I don't know what to do about.

I configured FreeTDS like this:
./configure --prefix=$HOME --with-tdsver=5.0
I also tried it with --with-tdsver=4.2 and 4.6, but that didn't seem to
change anything.  With --with-tdsver=7.0, the library had an unresolved

I configured sqsh like this:
./configure  --prefix=/homes/kenmore/web/djm --with-static --with-devlib
I also tried it without --with-devlib, but again, that didn't seem
to make a difference.  I linked it with -lct -lsocket.

I used gcc 2.7.2.  I have set

When I run sqsh, I get this:

djm at webserve0 169 $ ./sqsh
sqsh-1.7 Copyright (C) 1995-1999 Scott C. Gray
This is free software with ABSOLUTELY NO WARRANTY
For more information type '\warranty'
Unknown property 7
connect: Cannot assign requested address
Unknown property 26

It does this even if I give it valid -P, -U, -D, and -H arguments,
except then the connect error message is "connect: Connection refused".
When I set SYBASE=/usr/vendor/sybase and run isql, that works.

What do these FreeTDS error messages mean?  I also compiled them on
BSD/OS 4.0.1 and got the same error messages.

More information about the FreeTDS mailing list