What do these errors mean?

David MacKenzie djm at web.us.uu.net
Thu Oct 21 06:03:41 EDT 1999

I'm trying to use FreeTDS 0.47 and sqsh 1.7 to access a Sybase database
running on Solaris 2.5.1.  It produces some error messages, below, that
I don't know what to do about.

I configured FreeTDS like this:
./configure --prefix=$HOME --with-tdsver=5.0
I also tried it with --with-tdsver=4.2 and 4.6, but that didn't seem to
change anything.  With --with-tdsver=7.0, the library had an unresolved

I configured sqsh like this:
./configure  --prefix=/homes/kenmore/web/djm --with-static --with-devlib
I also tried it without --with-devlib, but again, that didn't seem
to make a difference.  I linked it with -lct -lsocket.

I used gcc 2.7.2.  I have set

When I run sqsh, I get this:

djm at webserve0 169 $ ./sqsh
sqsh-1.7 Copyright (C) 1995-1999 Scott C. Gray
This is free software with ABSOLUTELY NO WARRANTY
For more information type '\warranty'
Unknown property 7
connect: Cannot assign requested address
Unknown property 26

It does this even if I give it valid -P, -U, -D, and -H arguments,
except then the connect error message is "connect: Connection refused".
When I set SYBASE=/usr/vendor/sybase and run isql, that works.

What do these FreeTDS error messages mean?  I also compiled them on
BSD/OS 4.0.1 and got the same error messages.

More information about the FreeTDS mailing list