[cc-devel] error response for REST API calls

Nathan Yergler nathan at creativecommons.org
Mon Sep 21 16:09:07 EDT 2009


Hi Turadg,

That was a really bone-headed bug introduced by my last fix. I've
rolled out a bug fix.

We do have a test suite; I stupidly neglected to run it before
deploying my last fix.  I've confirmed that the test suite would have
caught this bug.  Thanks for the report; I'll try to be smarter about
this sort of thing in the future :).

Nathan

On Mon, Sep 21, 2009 at 11:46 AM, Turadg Aleahmad <turadg at cmu.edu> wrote:
> hi folks,
> I've run into another problem with the REST APIs.  I think it started with
> the update that fixed the other problem.  I've described it on the bug
> report for the CC module for
> Drupal, http://drupal.org/node/581998#comment-2067470.
> The CC module requests this URL,
> http://api.creativecommons.org/rest/1.5/simple/chooser?jurisdiction=us
>
> but it returns HTTP code 500, internal server error. This was working
> previously and the API docs say this is a correct request:
>
> http://api.creativecommons.org/docs/readme_15.html#simple-chooser
>
> Am I correct that this is a bug?  If so, estimate on a fix?  Also, are there
> any unit tests on the API?  This would be an easy one to catch.
>
> Turadg Aleahmad
> PhD student, HCII
>
> _______________________________________________
> cc-devel mailing list
> cc-devel at lists.ibiblio.org
> http://lists.ibiblio.org/mailman/listinfo/cc-devel
>
>



More information about the cc-devel mailing list