[bittorrent] UT peer connections

Jon Bellamy y2jb at hotmail.co.uk
Thu Jan 21 07:37:04 EST 2010


Just to confirm, i am not disconnecting, UTorrent is is disconnecting from
me.

The connections do seem to die when data has stopped being sent

and keep alive & HAVE messages seem to be at the end of every log.

I'll measure the period between actual data and disconnection and 
post back. 



However why is UTorrent disconnecting if there are no REQUEST / PIECE

messages being sent? Azeureus seems to be content to hold connections

for long periods if for example I am interested but am being choked. It 

seems bizare that UT would disconnect peers just because it has been

choking them for a period of time. Can you confirm that this is the way

UT operates?


> Date: Thu, 21 Jan 2010 07:40:17 -0400
> From: dwknight at depthstrike.com
> To: y2jb at hotmail.co.uk
> CC: bittorrent at lists.ibiblio.org
> Subject: Re: [bittorrent] UT peer connections
> 
> How long after sending ACTUAL data (sending or receiving a piece, not
> keepalive since those don't count as activity on uT's side) are you
> disconnecting from these peers?
> 
> Jon Bellamy wrote:
> > I've noticed that my client cannot seem to hold a connection to UTorrent
> > peers for longer than about 30mins - 1 hour. After this time all the UT
> > peers seem to have lost connection. The strange thing is that it only
> > seems to be UTorrent peers that this happens with, Azeureus, BitLord,
> > BitCommet etc peers are left working away and my client can happily sit
> > there for 24 hours+ and downlaod a complete 4gb+ torrent in one session
> > (just with no UT peers left after the first hour).
> > 
> > I am sure that i am not sending bad messages as other peers are not
> > disconnecting me and i have logs showing long data exchanges with
> > UTorrent peers (1 hour of sending and receiving pieces, then connection
> > lost). I also have keep alive messages implemented so its not that. The
> > UT peers are not disconnecting bang on the hour mark, some go after only
> > 5 minutes but after one hour they are all gone. I am using plain text
> > connections with no encryption.
> > 
> > The torrents i have been testing on have been large seed / peer torrents
> > with thousands of peers. I have observed around 15 UTorrent peers when
> > the torrent first starts up and they gradually disconnect over the first
> > hour. Is this something anyone else has seen or perhaps some behaviour
> > of UTorrent that i am unaware of? Any suggestions would help me out a
> > great deal.
> > 
> > Thanks Guys.
> > 
> > ------------------------------------------------------------------------
> > Do you have a story that started on Hotmail? Tell us now
> > <http://clk.atdmt.com/UKM/go/195013117/direct/01/>
> > 
> > 
> > ------------------------------------------------------------------------
> > 
> > _______________________________________________
> > BitTorrent mailing list
> > BitTorrent at lists.ibiblio.org
> > http://lists.ibiblio.org/mailman/listinfo/bittorrent
 		 	   		  
_________________________________________________________________
Got a cool Hotmail story? Tell us now
http://clk.atdmt.com/UKM/go/195013117/direct/01/
-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://lists.ibiblio.org/pipermail/bittorrent/attachments/20100121/f5458bf7/attachment.html 


More information about the BitTorrent mailing list