[bittorrent] UT peer connections

Jon Bellamy y2jb at hotmail.co.uk
Thu Jan 21 06:25:02 EST 2010










Sorry bad formatting, reformatted...









I've noticed that my client cannot seem to hold a connection to UTorrent 
peers for longer than about 30mins - 1 hour. After this time all the UT 
peers seem to have lost connection. The strange thing is that it only seems 
to be UTorrent peers that this happens with, Azeureus, BitLord, 
BitCommet etc peers are left working away and my client can happily sit 
there for 24 hours+ and downlaod a complete 4gb+ torrent in one 
session (just with no UT peers left after the first hour). 

I am sure that i am not sending bad messages as other peers are not 
disconnecting me and i have logs showing long data exchanges with 
Torrent peers (1 hour of sending and receiving pieces, then connection lost). 
I also have keep alive messages implemented so its not that. The UT peers 
are not disconnecting bang on the hour mark, some go after only 5 minutes 
but after one hour they are all gone. I am using plain text connections with 
no encryption.

The torrents i have been testing on have been large seed / peer torrents 
with thousands of peers. I have observed around 15 UTorrent peers when 
the torrent first starts up and they gradually disconnect over the first hour. 
Is this something anyone else has seen or perhaps some behaviour of 
UTorrent that i am unaware of? Any suggestions would help me out a 
great deal.

Thanks Guys.
 		 	   		  
Do you have a story that started on Hotmail? Tell us now 		 	   		  
Not got a Hotmail account? Sign-up now - Free 		 	   		  
_________________________________________________________________
Tell us your greatest, weirdest and funniest Hotmail stories
http://clk.atdmt.com/UKM/go/195013117/direct/01/
-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://lists.ibiblio.org/pipermail/bittorrent/attachments/20100121/fabfc3e6/attachment.html 


More information about the BitTorrent mailing list